Download MetaTrader 5

Make a Fibo line disappear

To add comments, please log in or register
Do you want to know about the MQL5.community development? Have a look at the Wall!
steveF
48
steveF 2014.03.08 18:38 

Hello,

I'm working on an indicator and using the fibo tool to plot lines. Everything works as I want except one minor thing.

I would like to get rid of the fibo slanted line shown below in first screen shot..

In MT4, I can edit the object and pick Color = NONE and it disappears (see bottom screen shot).

In my code, I cannot seem to find the value to use . I try the below CLR_NONE and the line still shows as black (see first screen shot).

ObjectSet(FName ,OBJPROP_COLOR,CLR_NONE);

Is there some value I can use in my code to make this line disappear?

Thank you in advance,

Steve



fibo1

Want it to look like this.

fibo2

steveF
48
steveF 2014.03.08 19:02  

Unfortunately this looks like a "bug" problem with Build 600.

On build 509, the code does make the line disappear and shows "NONE" in the parameter box

Notice the difference in behavior of the same code in the object properties.


Build 509

ObjectSet(FName ,OBJPROP_COLOR,CLR_NONE);


Build 600

ObjectSet(FName ,OBJPROP_COLOR,CLR_NONE);


steveF
48
steveF 2014.03.08 19:11  

I have solved my problem.

In build 509, using Print to see the value of CLR_NONE = -1

In build 600, using Print to see the value of CLR_NONE = 4294967925

So the issue is in build 600 compiler for this constant.



If Use the following code in Build 600 my problem is solved:

 ObjectSet(FName ,OBJPROP_COLOR,-1);
Alain Verleyen
Moderator
30752
Alain Verleyen 2014.03.08 23:12  
steveF:


I have solved my problem.

In build 509, using Print to see the value of CLR_NONE = -1

In build 600, using Print to see the value of CLR_NONE = 4294967925

So the issue is in build 600 compiler for this constant.



If Use the following code in Build 600 my problem is solved:

Build 600 is obsolete. This bug is already corrected in current build 610.

Please double posts, it's useless. Thank you.

Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.03.08 23:16  
steveF:


Unfortunately this looks like a "bug" problem with Build 600.

On build 509, the code does make the line disappear and shows "NONE" in the parameter box

Notice the difference in behavior of the same code in the object properties.

Please see here: https://www.mql5.com/en/forum/149271/page64#923127
steveF
48
steveF 2014.03.09 03:30  

Sorry I did not know build 600 is obsolete. It is latest version which downloaded from my broker.

Also did not mean to double post. First one was a question that I solved shortly after posting.

Second post was to report the bug. I did search and didn't find it first.

Once again, sorry if I didn't post correctly.

I appreciate this forum and thank you as always for the quick responses!

--Steve

steveF
48
steveF 2014.03.09 06:28  

I updated my build to 616 by connecting to Metaquotes.

This bug still exists in build 616.Same behavior, CLR_NONE does not work.


--Steve

qjol
3243
qjol 2014.03.09 07:46  
what about clrNONE ?
Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.03.09 08:59  
steveF:


I have solved my problem.

In build 509, using Print to see the value of CLR_NONE = -1

In build 600, using Print to see the value of CLR_NONE = 4294967925

So the issue is in build 600 compiler for this constant.



If Use the following code in Build 600 my problem is solved:

I already replied but someone helpfully removed my post.

In build 509 CLR_NONE is . . .

CLR_NONE 0xFFFFFFFF Indicates empty state of colors.

In build 600 CLR_NONE is . . .

CLR_NONE, clrNONE

Absence of color. Indicates empty state of colors

-1

Alain Verleyen
Moderator
30752
Alain Verleyen 2014.03.09 09:21  
RaptorUK:

I already replied but someone helpfully removed my post.

In build 509 CLR_NONE is . . .

In build 600 CLR_NONE is . . .

Sorry my mistake. Removed the double post too quickly. I should not do that so late.
Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.03.09 10:00  
angevoyageur:
Sorry my mistake. Removed the double post too quickly. I should not do that so late.
12
To add comments, please log in or register