Download MetaTrader 5

MT4 B600 SendMail Problem

To add comments, please log in or register
george
24
george  

Hello Forumers,

Ever since the upgrade to B600, the SendMail command does not work for my EA any more and I kept getting the error message: "Mail: 550 smtp envelope sender must be valid".

SendMail was working properly in Build 509 before the upgrade to B600.

I have been trying to resolve this problem for the past 24 hours with no avail and it is driving me nuts.

I really hope some kind soul out there can help solve my problem.

Thank you in advance!

Simon Gniadkowski
Moderator
18021
Simon Gniadkowski  
georgechen:

Hello Forumers,

Ever since the upgrade to B600, the SendMail command does not work for my EA any more and I kept getting the error message: "Mail: 550 smtp envelope sender must be valid".

SendMail was working properly in Build 509 before the upgrade to B600.

I have been trying to resolve this problem for the past 24 hours with no avail and it is driving me nuts.

I really hope some kind soul out there can help solve my problem.

Thank you in advance!

Read some other threads on the forum, it's a commonly reported issue . . . it may have been fixed but not released yet.
george
24
george  

Thanks for your response. Yes, I have search for all possible threads on this subject, with no avail. It has got to do with B600 as everything were fine before this.

If Metaquotes is monitoring this forum, please fix this problem ASAP as it is fundamental. Thanks

Alain Verleyen
Moderator
32764
Alain Verleyen  
georgechen:

Thanks for your response. Yes, I have search for all possible threads on this subject, with no avail. It has got to do with B600 as everything were fine before this.

If Metaquotes is monitoring this forum, please fix this problem ASAP as it is fundamental. Thanks

Have you tried build 603 ? I received a comment from MQ that the email bug was fixed in this build.
george
24
george  
angevoyageur:
Have you tried build 603 ? I received a comment from MQ that the email bug was fixed in this build.


Tks mate. Per ur advice I hv upgraded to B604, but to my dismay the same error message "Mail: 550 smtp envelope sender must be valid" appeared.

FYI, I did Test mail which was successfully received, but when it come to SendMail, the error message appeared. B509 was working normally all along.

Would MQ please look into this problem asap. Tks

Alain Verleyen
Moderator
32764
Alain Verleyen  
georgechen:


Tks mate. Per ur advice I hv upgraded to B604, but to my dismay the same error message "Mail: 550 smtp envelope sender must be valid" appeared.

FYI, I did Test mail which was successfully received, but when it come to SendMail, the error message appeared. B509 was working normally all along.

Would MQ please look into this problem asap. Tks

I strongly suggest you to write to ServiceDesk (on mql5.com), with details about your mail configuration and code where you are using SendMail.
micclly
189
micclly  

I double this on the another topic.

I've created just workaround library (for temporary use until MetaQuotes fix, maybe few days).

Get it from here

https://github.com/micclly/mt4-mailer/releases

See README how to use:

https://github.com/micclly/mt4-mailer/blob/master/README.md
micclly
189
micclly  
georgechen:

FYI, I did Test mail which was successfully received, but when it come to SendMail, the error message appeared. B509 was working normally all along.


This is because the invalid From header, as reported here
To add comments, please log in or register