Download MetaTrader 5

MetaTrader4 Build 600 - how to recovery my old Meta Trader 4 Editor?

To add comments, please log in or register
Add our channel to friends and follow the news!
Piotr
1249
Piotr 2014.02.06 11:43 

All my experts do not work under 600 Compilation... what did you do?

What should I do in order to work under my old mq4 files? I need Meta Trader 4 editor not Meta Trader 5 editor.

darksideofthemoon
57
darksideofthemoon 2014.02.06 11:50  

Who told you that you have to recompile them?

Leave the .ex4 as is, and they will work (with some exceptions that deal with specific things).

Richard
78
Richard 2014.02.06 12:49  
2cent:

Who told you that you have to recompile them?

Leave the .ex4 as is, and they will work (with some exceptions that deal with specific things).


If someone wants to update or change an ea or indicator they will obviously have to recompile. If there is something in Build 600 that breaks existing code, we should be told about it.
darksideofthemoon
57
darksideofthemoon 2014.02.06 12:58  
rwbta:

If someone wants to update or change an ea or indicator they will obviously have to recompile. If there is something in Build 600 that breaks existing code, we should be told about it.

We have been told about it; you read, you know.

Piotr
1249
Piotr 2014.02.06 19:48  
2cent:

We have been told about it; you read, you know.


Can I pls any link
Alain Verleyen
Moderator
30739
Alain Verleyen 2014.02.06 20:00  
puncher:

Can I pls any link
What is your concrete problem ?
Piotr
1249
Piotr 2014.02.07 08:23  

My concrete problem is:


Under Meta Trader 4 Build 600 Meta Editor all my experts do not compile properly as before were in previous version of Meta Trader 4 Build under 600.
Meta Editor Build 600 drastically changed.

Ex Ovo Omnia
3153
Ex Ovo Omnia 2014.02.07 08:43  

He asked for possibility to edit and compile mq4 files using the 509 editor/compiler, to be used in the new 600 as ex4. Of course, it is possible. You need the directory structure of the old 509 metatrader, and place the old metaeditor/metalang in its root.

Files:
Piotr
1249
Piotr 2014.02.07 09:11  
Ovo:


He asked for possibility to edit and compile mq4 files using the 509 editor/compiler, to be used in the new 600 as ex4. Of course, it is possible. You need the directory structure of the old 509 metatrader, and place the old metaeditor/metalang in its root.



Still is something wrong. I copy the files:

#1# metaeditor.exe and metalang.exe (509) to my metatrader 4 (600) folder

#2# config/metaeditor.ini (509) to the folder config of my metatrader 4 (600) folder

I start metatrader 4 and run meteditor. Then the metaditor is OK. But when I compile the file mq4 the editor is closing during the compilation and under metatrader 4 platform (Build 600) I have no all my experts.

I can see them only under metaeditor but I can not compile them

Ex Ovo Omnia
3153
Ex Ovo Omnia 2014.02.07 10:18  
puncher:

Still is something wrong. I copy the files:

#1# metaeditor.exe and metalang.exe (509) to my metatrader 4 (600) folder

#2# config/metaeditor.ini (509) to the folder config of my metatrader 4 (600) folder

I start metatrader 4 and run meteditor. Then the metaditor is OK. But when I compile the file mq4 the editor is closing during the compilation and under metatrader 4 platform (Build 600) I have no all my experts.

I can see them only under metaeditor but I can not compile them


Just unzip the attachment, move your experts folder with mq4 files here. Edit/compile them by Metaeditor, move the ex4 to your 600 installation. Do not merge the unzipped folder with any installation.
12
To add comments, please log in or register