Download MetaTrader 5

StringFind not working in the latest update.

To add comments, please log in or register
Andrew West
223
Andrew West  
if (StringFind(IgnorePair,TempSymbol, 0) < 0) <=== any reason this line no longer works?
whroeder1
14781
whroeder1  
Since strings are now wide, the question is how do you get your strings.
Andrew West
223
Andrew West  
WHRoeder:
Since strings are now wide, the question is how do you get your strings.

Problem is there is no simple documents listing the changes and how to use them, have to spend hours searching.
Simon Gniadkowski
Moderator
18003
Simon Gniadkowski  
MrLong:

Problem is there is no simple documents listing the changes and how to use them, have to spend hours searching.
If you ask for help and then someone trying to help you asks you a question it is in your interest to answer . . . maybe you don't want help any longer ?
Andrew West
223
Andrew West  
RaptorUK:
If you ask for help and then someone trying to help you asks you a question it is in your interest to answer . . . maybe you don't want help any longer ?


No I still have the problem, I didn't interpret anyone was asking a question, I need to know why StringFind has stopped working, any help would be welcome.
Simon Gniadkowski
Moderator
18003
Simon Gniadkowski  
MrLong:

No I still have the problem, I didn't interpret anyone was asking a question, I need to know why StringFind has stopped working, any help would be welcome.

WHRoeder:
Since strings are now wide, the question is how do you get your strings.
gchrmt4
356
gchrmt4  
MrLong:

No I still have the problem, I didn't interpret anyone was asking a question, I need to know why StringFind has stopped working, any help would be welcome.
It may or may not be relevant to what you are doing, but I seem to found string-handling problems in v600 and v602: https://www.mql5.com/en/forum/149360. Something similar might be affecting your use of StringFind()
Andrew West
223
Andrew West  
gchrmt4:
It may or may not be relevant to what you are doing, but I seem to found string-handling problems in v600 and v602: https://www.mql5.com/en/forum/149360. Something similar might be affecting your use of StringFind()

Yes, exactly the same, does not work on initial run but does thereafter, many thanks for your help, I'll work around it until it becomes fixed.

dietcoke
23
dietcoke  

I am also getting corrupt strings:


When i run the test script attached on build 604, the alert is corrupted.These functions work perfectly in B509

Files:
ydrol
593
ydrol  

There is a lot of code there, why not make the smallest test case possible?

ps we now have standard functions StringTrimLeft, StringTrimRight, StringToUpper, StringToLower

gchrmt4
356
gchrmt4  
dietcoke:

When i run the test script attached on build 604, the alert is corrupted.These functions work perfectly in B509

(I am also seeing the same problems continuing in v604. No change to everything reported in https://www.mql5.com/en/forum/149360)
123
To add comments, please log in or register