Download MetaTrader 5

new mt4 version 574 giving warnings

To add comments, please log in or register
Examine the Top MetaTrader 5 signals. Choose the best one and subscribe to it!
pontuso5
376
pontuso5 2014.01.25 17:06 
Hi all, im wondering why i get all these warnings when i compile my old EA:s. They are working fine on build 509
Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.01.25 17:14  
pontuso:
Hi all, im wondering why i get all these warnings when i compile my old EA:s. They are working fine on build 509
It's because the mql4 used in build 574 and 577 is not the same as the mql4 used in build 509 and earlier.
pontuso5
376
pontuso5 2014.01.25 17:22  

Hmm okay.

Since they are updating the mt4, and know there is a new langugae and all, do you think it's a good idea to recode all my EA:s and change platform to MT5?

Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.01.25 17:26  
pontuso:

Hmm okay.

Since they are updating the mt4, and know there is a new langugae and all, do you think it's a good idea to recode all my EA:s and change platform to MT5?

Have you seen how trading is handled in MT5 ? Orders, Deals and Positions ? do you understand it ?
pontuso5
376
pontuso5 2014.01.25 17:30  
RaptorUK:
Have you seen how trading is handled in MT5 ? Orders, Deals and Positions ? do you understand it ?


Haven't been using MT5 very much.

Do you think it's hard to learn compared to MT4?

Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.01.25 17:40  
pontuso:

Haven't been using MT5 very much.

Do you think it's hard to learn compared to MT4?

Harder, yes, without a doubt.
Alain Verleyen
Moderator
30742
Alain Verleyen 2014.01.25 17:55  
pontuso:

Hmm okay.

Since they are updating the mt4, and know there is a new langugae and all, do you think it's a good idea to recode all my EA:s and change platform to MT5?

It's not needed to change your platform. You still can use the same language as before, but with some more strict rules. The new language isn't mandatory.

Warnings are only warnings, it doesn't break your code but they attract your attention on some potential problem. However, my advice is to correct these warnings. If you don't understand them simply ask for help here.

Gatoreye
52
Gatoreye 2014.01.25 20:39  

My broker also released the new version build 574 to one of my live accounts.


Here are some of the things I found in my program:

1) MT4i mirror trading EA failed because it was unable to create a log file.

2) char is a reserved word now if you try to re-compile under MetaEditor 5.0 Build 882.

3) If you don't want to re-compile, the programs compiled under 509 works fine as is.

4) Strategy Tester runs much faster.

5) The new release created a new folder called MQL4. The newly compiled programs must go in here.

rgerasimen
251
rgerasimen 2014.01.27 09:55  

Does anybody care that new MT4 terminal (build > 509) takes over 15% of CPU even with all charts/tabs closed?

https://www.dropbox.com/s/z5ocnps4aumm28f/Screenshot%202014-01-26%2021.27.44.png

https://www.dropbox.com/s/8nve4xr7p2pa5k0/Screenshot%202014-01-26%2021.26.45.png

Simon Gniadkowski
Moderator
18001
Simon Gniadkowski 2014.01.27 11:13  
rgerasimen:

Does anybody care that new MT4 terminal (build > 509) takes over 15% of CPU even with all charts/tabs closed?

https://www.dropbox.com/s/z5ocnps4aumm28f/Screenshot%202014-01-26%2021.27.44.png

https://www.dropbox.com/s/8nve4xr7p2pa5k0/Screenshot%202014-01-26%2021.26.45.png

Do not double post . . .
To add comments, please log in or register