New Version of MetaTrader 4 Client Terminal Build 482: one click trading panel and publishing screenshots of charts on MQL5.com - page 4

To add comments, please log in or register
Simon Gniadkowski
17205
Simon Gniadkowski  
sect8:

Is there a way to disable  the new one click panel? my ea uses the comment field and no longer displays properly.

I find this very annoying. please make it optional 

It has been said time and time again that the comment field is not a reliable thing to use . . . now you know why.
sokramm
56
sokramm  
sect8:

Is there a way to disable  the new one click panel? my ea uses the comment field and no longer displays properly.

I find this very annoying. please make it optional


thank you

If you use the little arrow on the top left of the chart next to the symbol name, it hides the one click panel and then the comment should show as before.
Simon Gniadkowski
17205
Simon Gniadkowski  
RaptorUK:
It has been said time and time again that the comment field is not a reliable thing to use . . . now you know why.

Ahhhhh . . . you meant using  Comment()  not the comment part of an OrderSend()
Eric
153
Eric  

i have a script i use to run everyday about 5 to 10 time per day 2 month ago.

i try to run same script and i keep receiving error #3 after my order send

2 month ago it worked without any problem

what's the problem with sending pending order ? sometings change ?

Simon Gniadkowski
17205
Simon Gniadkowski  
Gachette:

i have a script i use to run everyday about 5 to 10 time per day 2 month ago.

i try to run same script and i keep receiving error #3 after my order send

You can see what   error 3  is,  without seeing your code it hard to give any specific help.
Eric
153
Eric  
RaptorUK:
You can see what   error 3  is,  without seeing your code it hard to give any specific help.

ok, will give the line of code tonight but i lost my evening yesterday looking into the changes annonced for built 482 and nowhere I see something has changed with ordersend or pending orders in this built, so why a script would run without any problem 2 months ago (i have use it like 200 times or more) and now send me a error 3 for wrong parameters... something must have change but why I cant find it in the change ?

 I could easily correct the code myself only if I know something have change

but again, no change related to sl, tp, lot, slippage, open price, ....... 

Simon Gniadkowski
17205
Simon Gniadkowski  
Gachette:

ok, will give the line of code tonight but i lost my evening yesterday looking into the changes annonced for built 482 and nowhere I see something has changed with ordersend or pending orders in this built, so why a script would run without any problem 2 months ago (i have use it like 200 times or more) and now send me a error 3 for wrong parameters... something must have change but why I cant find it in the change ?

 I could easily correct the code myself only if I know something have change

but again, no change related to sl, tp, lot, slippage, open price, ....... 

Maybe your Broker has changed a Symbol parameter and your code isn't compensating for it,  for example MODE_LOTSTEP or MODE_TICKSIZE.
Unk Nown
59
Unk Nown  

I think to complete one click trading functionality, "default lot size" should be integrated. And also default lot size should be set as a percentage of maximum available lot (in Options). For example If I always want to open maximum available lot, I can define 100% in default lot size (instead of defining a fixed lot size)  so it will dynamically be adjusted by free available margin. 

Eric
153
Eric  
RaptorUK:
Maybe your Broker has changed a Symbol parameter and your code isn't compensating for it,  for example MODE_LOTSTEP or MODE_TICKSIZE.

Raptor:  as you may know, it is easier to blame the new version than the programmer or the trader... 

the MAIN change since that 2 months i use this script, (when it worked pretty well) is ... not the new built, but really that 2 months have passed. 

 I finally manage to find  why i was always receiving this error 3.  I am a bit shame to say it out loud here, as it is a newbi mistake but as it may help someone receiving this error code when trying to send pending order....

check the expiration date!

the script was still trying to send a march expiration date, that is why it was working well 2 months ago and not yesterday

 

thank you for you clues 

Simon Gniadkowski
17205
Simon Gniadkowski  
Gachette:

Raptor:  as you may know, it is easier to blame the new version than the programmer or the trader... 

the MAIN change since that 2 months i use this script, (when it worked pretty well) is ... not the new built, but really that 2 months have passed. 

 I finally manage to find  why i was always receiving this error 3.  

Glad to hear you found the issue,  don't feel bad we all make mistakes and poor assumptions.  :-)
To add comments, please log in or register