Why does sound alerts not work on Vista?

freemenn
138
freemenn  

Hi,

i have installed metatrader on vista and also on XP machine.

I note that sound alerts, for indicators where they has popup alerts and sould alerts, doesn't work on XP machine whiel it works well on XP machine.

On Vista i see only the popup but no sould alert.

Is there any workaround to fix this?

PS: if i call the sould file manually it works fine

Thanks a lot for any help

freemenn
138
freemenn  

no one know what could be the problem and how to fix?

thanks again

Ray
2646
Ray  

I don't have Vista.

Sounds for MetaTrader are in the /sounds folder inside the MetaTrader installation. Have you got sound files there?

Are there any errors in the experts or journal tabs?

write a script/indicator/ea using PlaySound("Alert.wav"); See what happens.

freemenn
138
freemenn  

hi,

thanks for replay.No, there is no error message in journal tab. Usually all souds from all other applications works fine.

Sorry i am not a programmer and cannot write s script to test as you have mentioned.

Ray
2646
Ray  
//+------------------------------------------------------------------+
//|                                                    SoundTest.mq4 |
//|                      Copyright © 2008, MetaQuotes Software Corp. |
//|                                        http://www.metaquotes.net |
//+------------------------------------------------------------------+
#property copyright "Copyright © 2008, MetaQuotes Software Corp."
#property link      "http://www.metaquotes.net"

#property indicator_chart_window
//+------------------------------------------------------------------+
//| Custom indicator initialization function                         |
//+------------------------------------------------------------------+
int init()
  {
//---- indicators
//----
   return(0);
  }
//+------------------------------------------------------------------+
//| Custom indicator deinitialization function                       |
//+------------------------------------------------------------------+
int deinit()
  {
//----
   
//----
   return(0);
  }
//+------------------------------------------------------------------+
//| Custom indicator iteration function                              |
//+------------------------------------------------------------------+
int start()
  {
   int    counted_bars=IndicatorCounted();
//----
   PlaySound("Alert.wav");
   int error = GetLastError();
   if(error != 0) Alert("Error Number " + error + " occurred");
//----
   return(0);
  }
/
freemenn
138
freemenn  

Hi,

thanks a lot for this. I suppose i have to put this to save as: .mq4 file and the put into the /experts folder. Ok i made this but when i drag&drop on to a chart nothing happens. (also i see the EA, in folder on the left in MT, is no highlighted as you can see in attached screenshoot.)

thanks for any help you may give.

Files:
Ray
2646
Ray  

It is an Indicator, not an EA.

Put it in /experts/indicators

Open it in Metaeditor and compile it,or restart metatrader.

Drag it to the chart from Custom Indicators area of Navigator.

nate
7
nate  
freemenn:

Hi,

i have installed metatrader on vista and also on XP machine.

I note that sound alerts, for indicators where they has popup alerts and sould alerts, doesn't work on XP machine whiel it works well on XP machine.

On Vista i see only the popup but no sould alert.

Is there any workaround to fix this?

PS: if i call the sould file manually it works fine

Thanks a lot for any help

I have Vista, and the Alert sounds work for me.



Nate

[Deleted]  
freemenn wrote >>

Hi,

i have installed metatrader on vista and also on XP machine.

I note that sound alerts, for indicators where they has popup alerts and sould alerts, doesn't work on XP machine whiel it works well on XP machine.

On Vista i see only the popup but no sould alert.

Is there any workaround to fix this?

PS: if i call the sould file manually it works fine

Thanks a lot for any help

Check and see if you have alerts turned on. At the top left go to Tools>Options>Events. Make sure that "Enable" is checked. Also, if there is an X over the alert bell double click and this will turn it on.