Strategietester plötzlich sehr langsam

 

Der Strategietester läuft bei mir auf einmal sehr langsam. Wo ich angefangen habe zu testen, brauchte er für ein Jahr ca. eine stunde. Mittlerweile braucht er 7-9 Std.

Schreibt er sich irgendwo rein, das ich von Zeit zu Zeit löschen muß, oder woran kann es liegen?

 
0Jeremy0:

Der Strategietester läuft bei mir auf einmal sehr langsam. Wo ich angefangen habe zu testen, brauchte er für ein Jahr ca. eine stunde. Mittlerweile braucht er 7-9 Std.

Schreibt er sich irgendwo rein, das ich von Zeit zu Zeit löschen muß, oder woran kann es liegen?

Es liegt am Code. Starte mal den Profiler: Editor => Debug => Profiling an Hand historischer Daten beginnen.

Siehe dazu: https://www.metatrader5.com/de/metaeditor/help/development/profiling

Code-Profiling - Programme entwickeln - MetaEditor Hilfe
Code-Profiling - Programme entwickeln - MetaEditor Hilfe
  • www.metatrader5.com
Profiling bedeutet das Sammeln von Programmparametern während der Ausführung. Während eines Profiling werden die Ausfü...
 

Danke für deine Antwort.


Ich verstehe nur nicht, warum die Anfangstest so schnell gingen und das sie dann auf einmal so lange dauern. Nachdem 15 Test, ist es erst passiert. Dabei habe ich nichts verändert.

 
0Jeremy0:

Danke für deine Antwort.


Ich verstehe nur nicht, warum die Anfangstest so schnell gingen und das sie dann auf einmal so lange dauern. Nachdem 15 Test, ist es erst passiert. Dabei habe ich nichts verändert.

Schau Dir die Speicherverwendung an (RAM) vielleicht beginnt nach einiger Zeit der EA den RAM mit der HD zu swappen: zu viel zu gleich bei zu wenig RAM.
 

Habe jetzt nachgeschaut. RAM läuft zwischen 50-60%, wenn ich backteste. 

Habe jetzt nochmal MT4 neu installiert und ein Jahr eingestellt. Drei Monate läuft er so wie früher und dann wird er extrem langsam.

Habe das schonmal gemacht, mit bis jetzt gleichen Ergebnis und dann bei zweiten Test, war er von Anfang an extrem langsam.

 
0Jeremy0:

Habe jetzt nachgeschaut. RAM läuft zwischen 50-60%, wenn ich backteste. 

Habe jetzt nochmal MT4 neu installiert und ein Jahr eingestellt. Drei Monate läuft er so wie früher und dann wird er extrem langsam.

Habe das schonmal gemacht, mit bis jetzt gleichen Ergebnis und dann bei zweiten Test, war er von Anfang an extrem langsam.

Da das nur bei Dir so ist, liegt das Problem bei Dir. Aber warum das alte MT4? Niemand kauft sich einen neuen einen Wagen, der vor 10 Jahren konzipiert wurde und nur noch so mitläuft.

 

Weil der Programmierer auf Gebrauchtwagen stand, aber Neuwagenpreise genommen hat.

(Nicht aus diesen Forum und aus dem deutschsprachigen Raum)


Also Fazit ist jetzt, viel Geld für nichts ausgegeben.


Oder kann man da noch etwas retten?

 
0Jeremy0:

Weil der Programmierer auf Gebrauchtwagen stand, aber Neuwagenpreise genommen hat.

(Nicht aus diesen Forum und aus dem deutschsprachigen Raum)


Also Fazit ist jetzt, viel Geld für nichts ausgegeben.


Oder kann man da noch etwas retten?

wohl nur der Programmierer, wir kennen den Code ja nicht

aber warum nehm ich einen Progger der nicht tut was er soll?

 
Machst Du einen visuellen Test und der EA produziert viel Grafik, das kann auch stark verlangsamen.
 
amando:

wohl nur der Programmierer, wir kennen den Code ja nicht

aber warum nehm ich einen Progger der nicht tut was er soll?

Weil er sehr viele gute Bewertungen hatte. Ist eine sehr lange Geschichte...
 
Carl Schreiber:
Machst Du einen visuellen Test und der EA produziert viel Grafik, das kann auch stark verlangsamen.
Nein, ich mache es ohne visuellen Test.
Grund der Beschwerde: