Download MetaTrader 5

Waiting for Update Error - When debugging with Start with History Data

To add comments, please log in or register
No time to learn MQL5? Order your application from a developer!
gr101
196
gr101 2015.09.13 15:22 

Hi,

I've been getting the "Waiting for Update" message intermittently when running MQL Scripts from the MetaEditor.

Has anyone else experienced this and know how to resolve it?

Steps to create:

1) I run an EA from Metaeditor in history mode and am able to debug successfully

2) Suddenly it'll start showing me the "Waiting for Update" when it opens up the Strategy Tester for a given pair (which was working fine seconds earlier, see step 1)

Fixes:

1) Sometimes I'm able to fix this by closing all the windows and re-opening them (Run as Administrator)

2) Sometimes re-installing metatrader without uninstalling it fixes it

3) Sometimes uninstalling (and NOT removing personal data when it prompts me to). Then reinstalling it.

4) Everytime uninstalling (and removing personal data when it prompts me to. Then reinstalling it.

Some info on my system:

OS: Windows 8.1 Enterprise
MetaTrader 5
Version 5.00 build 1159


### From the log files:

HP    0    18:21:55.572    Startup    MetaTester 5 x64 build 1159 (22 Jun 2015)
KD    0    18:21:55.578    Server    MetaTester 5 started on 127.0.0.1:3000
DO    0    18:21:55.579    Startup    initialization finished
JM    0    18:21:56.032    127.0.0.1    login (build 1159)
CK    0    18:21:56.037    Network    38680 bytes of account info loaded
KL    0    18:21:56.037    Network    1490 bytes of tester parameters loaded
PF    0    18:21:56.037    Network    196 bytes of input parameters loaded
KQ    0    18:21:56.038    Network    479 bytes of symbols list loaded
DF    0    18:21:56.038    Tester    expert file added: Experts\EW3.ex5. 74439 bytes loaded
RP    0    18:21:56.050    Tester    initial deposit 10000.00 USD, leverage 1:500
DH    0    18:21:56.053    Tester    successfully initialized
EM    0    18:21:56.053    Network    82 Kb of total initialization data received
DD    0    18:21:56.053    Tester    Intel Core i7-4600M  @ 2.90GHz, 16070 MB
CP    0    18:21:57.107    Tester    log file "C:\Users\Machine1\AppData\Roaming\MetaQuotes\Tester\D0E8209F77C8CF37AD8BF550E51FF075\Agent-127.0.0.1-3000\logs\20150818.log" written
DG    0    18:21:57.267    Tester    tester agent shutdown started
RS    0    18:21:57.300    Tester    shutdown tester machine
gr101
196
gr101 2015.10.19 21:12  
Hi,

Has no one else experienced this?

It's really hampering me. It worked fine for a while (I started working in a Virtual Machine with Windows 7 on it) but now it's started up again.

I spend about 30% of my time trying to work around it.

Regards

To add comments, please log in or register