Download MetaTrader 5

Using Linex with EAs

To add comments, please log in or register
Publish your application in the Market - 7 million potential clients will see it
mattmiller55
330
mattmiller55 2015.04.28 09:50 

Hello Everyone,

I am considering purchasing a few EAs, but do not want to install them on an old Windows XP machine, I am running pure Linux (Ubuntu 64-bit) now and have been for sometime which is very stable and runs Metatrader very well, only issue is that it does not understand the "Market" installation method. It's been known for sometime and highlighted here: 

https://www.mql5.com/en/articles/625

 

I was wondering if anyone had found a solution to this problem when attempting to install an EA from the Market tab. I have tried installing it on a Windows XP machine and then copied all the folders and content across to the Linux computer and the Linux Metatrader platform can then see the EA, but it will not function (when selected nothing happens, no error messages, just does not run).

 

Downloading and installing code from the "Code Base" tab works fine. Is there anyway to use this method with the Market tab?

Or is there a way to purchase the EA from the Market tab by installing it onto the Windows XP machine temporarily and then transfer it across to the Linux computer afterwards?

 

I was trying not to have to purchase a Windows 7 or higher machine as I can do everything else in Linux so do not need the Windows machine for anything else other than this one function.  

 

Any help or advice would be grateful,

 Best regards,

 Matt 

MetaTrader 5 on Linux
MetaTrader 5 on Linux
  • 2013.01.18
  • MetaQuotes Software Corp.
  • www.mql5.com
Linux is a Unix-like computer operating system assembled under the model of free and open source software development and distribution. Linux systems are widely used in smartphones and server hardware. Many home PC users prefer it to MS Windows series. In this article, you will find out how to work in MetaTrader 5 via one of the Linux versions - Ubuntu.
Aleksei Beliakov
24160
Aleksei Beliakov 2015.04.29 19:39  
same problem in mt4 i think it's happens because we dont have browser in wine
mattmiller55
330
mattmiller55 2015.05.01 09:55  

I have managed to install firefox within wine, but this still gives the same problem. 

When purchasing an EA from the Market tab, is there another method to install the EA into my MT4 platform other than allowing the web browser to try and do this automatically?

For example can the EA be downloaded first and then installed (as is the case for the Code Base tab - this method works well), at the moment there appears to be no other option available when purchasing EAs.  

Alternatively is it possible to purchase an EA through the MT4 platform without having to use a web browser? 

To add comments, please log in or register