Download MetaTrader 5
To add comments, please log in or register
Find out how to install MetaTrader on Mac OS
Mihai Ionescu
1227
Mihai Ionescu 2011.04.24 20:56 

I am aware it could be something inside my indicator. But I'm at loss now.

It doesn't work, it doesn't show anything in experts, but compiles ok. 

Weird enough, I have an older mt5 from alpari installed, and there it works.

Something ever weirder happen when I started to debug it. The indicator worked afterwards, but just until the next restart.

 

I've installed a completely fresh mt5, but my indicator is still dead, doesn't show anything, I tried printf everywhere => no print, nothing. 

 

I don't even know where to start with resolving this issue. It's the first time I see something like this, no reaction from the indicator.

It's basically only events based. 

The events don't work. But the indicator doesn't seem to be stopped, because I've put a printf in deinit(), and nothing is printed.

Experts window is clean white (first time I see it as blank as this) 

Any idea why this happened since last update or updates? (I had to compile it recently, so I don't know since when this happens. It stopped working after this last compilation) 

Anyone was experiencing something like this before? 

Mihai Ionescu
1227
Mihai Ionescu 2011.04.26 03:03  

Some more observations:

1. if I debug the indicator, after restarting the terminal, the indicator works. Until the next compilation. If I compile again, I have to debug it first, then close everything, then the indicator will work after opening the terminat.

2. the journal tab doesn't display anything like error about the indicator.

 

it's really cumbersome to debug and restart the terminal every time I make a small change.

Anyone has a clue? 

Mihai Ionescu
1227
Mihai Ionescu 2011.05.05 16:27  

The issue has resolved since last update :)

Without any change in the indicator. 



/
To add comments, please log in or register