[solved] Strategy Tester Visualization hangs on "Waiting for Update"


Hi guys,

I used to experience intermitent issues with the Tester Visualization hanging on "Waiting for Update" but usually if I forced close it and retried a few times or changed the symbol it would start working again.

However, now I am completely stuck. No matter what symbol I try, how many times I restart MT5 or even the computer, it won't render visualizations anymore. 

Note that I did not change my EA or any configurations on either my EA or MT5 itself so this is not the cause. I ran one visualization fine, simply tried rerunning it and it won't start.

I've also tried removing the tester.tpl template or creating a new one without any indicators, and nothing seems to solve this. There were no updates on the MT5 software on my end.  Also tried deleting all history files, and ticks data from my file system. 

Now I do not know what to do. I rely heavily on the visualizer to help me refine my algorithms since I have many visual aid tools, but it simply won't start anymore, even if I wait for 5 or 10 minutes, it does not resume. 

Note: Regular simulations without the visualizer work fine. 

Note2: I found older threads suggesting to remove symbols, add them again, and open the chart window with the symbol. This has also not worked for me unfortunately. I am also properly logged in.

Has anyone ever experienced this? How should I proceed to solve this?

These are the logs I can see:


Hung on "Waiting for Update"


To anyone that suffers from this issue again, I resolved it by closing MT5 and removing all these folders/files:

find MQL5/Profiles/Tester/ -maxdepth 1 -mtime +7 -type f -iname "*.ini" -exec rm {} \;

find bases/XPMT5-*/symbols/ -type f -iname "*.dat" -exec rm {} \;

find bases/XPMT5-*/trades/* -type f -name "*.dat" -exec rm {} \;

find MQL5/Profiles/ -type f -name "*.chr" -exec rm {} \;

find MQL5/Profiles/ -type f -name "*.wnd" -exec rm {} \;

[ -f MQL5/Profiles/Templates/tester.tpl ] && mv MQL5/Profiles/Templates/tester.tpl MQL5/Profiles/Templates/_tester.tpl

rm -r bases/XPMT5-*/ticks/*

rm -r Tester/cache/

That's a bash script I use (using WSL on Windows), but it shows all the files I removed to get my visualization to work again. Created a script in case I ever need to run this again.

Not sure if I really needed to remove all of that, but that did the trick for me so I am happy. 

My root folder to run that is:






I've had the same problem for several weeks. First with an IC-Markets demo account. Reinstallation including deletion of data yielded nothing.

With a new Bleuberry account it went well for a week. Now I have the same problem there.

I then get reapeatedly the screen like above at @ Fernando Henrique Gielow. But sometimes that is even a bridge too far.

Then the figure appears as below (completely white). The session will not proceed. The only way is to stop the started session.

At another point, test visualization just continues as it should. It is all very irregular and seems to be related to changing periods or modeling.

It's not workable now.

For the MQL5 team: Is there a cause and can it be repaired,... is the a solution?

vusualisation white

Fernando Henrique Gielow I don't understand your solution. Anyway I have respect for your crafmanship! But I hope you don't mind I think it is not a sustanable solution.  So it is NOT SOLVED FOR ME AND THE COMMUNITY.

Fernando Henrique Gielow
Fernando Henrique Gielow
  • www.mql5.com
Trader's profile

first thing is to check for templates that use indicators.

See, tester.tmp and the one named after your EA


I am facing the same issues.

WAITING FOR UPDATE when the visualizer shows up.

Most times it does even show up.

Coincidence or not, this all started after one of the automatic updates a week ago or so.

Now, the visualizer does not show up automatically when you start a new tes.

I have tried many things.

A new installation and start from scratch solves the problem, but it will not be the right solution as we are specialists who could figure out the cause and solution for this problem, as long as it is not caused by the Metatrader software itself.

Does anybody know the definitive solution for this?


Hi all,

I have received a suggestion from ICMarkets regarding the strategy tester screen not showing (Waiting for Update or not showing at all) and they suggested me a trick which has worked for me.

But I am still testing to see if it really solves the problem for good.

The "trick" is to change the acces point in MT5, right lower corner of the MT5 interface.

Click ont the tiny bars next to the miliseconds and it will show up a series of options for servers, pick any and see if it solves the issue

Best regards to all

I ran into same problem 5 minutes ago. The problem started after adding parabolic SAR to my template. when I delete the template file strategy tester visualization works just fine but as soon as I create a template file it just won't work.
Is there any solution to this problem. I also use 2 ParabolicSARs and it seems not to work in the Strategy tester (Waiting for update).It works in in the "normal" test environment, but not on the visual mode. It worked a week ago. Now it doesn´t. Any suggestions.
RobRoy2709 #:
Is there any solution to this problem. I also use 2 ParabolicSARs and it seems not to work in the Strategy tester (Waiting for update).It works in in the "normal" test environment, but not on the visual mode. It worked a week ago. Now it doesn´t. Any suggestions.

See my solution

Hope it works for u