Zero Divide in Backtest MT4

To add comments, please log in or register
YThi MJ
134
YThi MJ  

Hi, 

I am getting Zero Divide in Backtest of an Expert for this Indicator. I added it as iCustom and there are indications in the script about how to add it as iCustom but it still gives Zero Divide. It skips it it the Backtest but it looks like in Live Demo it might be blocking it.

Do you know what should I do?

Keith Watford
Moderator
24883
Keith Watford  
I know that it is not obvious, but topics concerning MT4 and MQL4 have their own section.
In future please post in the correct section.
I will move your topic to the MQL4 and Metatrader 4 section.
Keith Watford
Moderator
24883
Keith Watford  

What error report are you getting?

The report will tell you which line of code is causing the zero divide and knowing that will be useful to find the problem.

William Roeder
22754
William Roeder  
YThi MJ: Do you know what should I do?

You know what, you know where, fix your broken code.

Kenneth Parling
14921
Kenneth Parling  
YThi MJ:

Hi, 

I am getting Zero Divide in Backtest of an Expert for this Indicator. I added it as iCustom and there are indications in the script about how to add it as iCustom but it still gives Zero Divide. It skips it it the Backtest but it looks like in Live Demo it might be blocking it.

Do you know what should I do?

I've sent you a PM 😉

Keith Watford
Moderator
24883
Keith Watford  
Comments that do not relate to this topic, have been moved to "Off Topic Posts".
YThi MJ
134
YThi MJ  
Kenneth Parling:

I've sent you a PM 😉

Thanks Kenneth. It is working perfectly  😃

To add comments, please log in or register