Need Help On Why My EA Suddenly Starts Skipping Trades

To add comments, please log in or register
trader_queen1
12
trader_queen1  
Hi folks was hoping someone could please help me understand what could be going on with my EA.

I wrote and EA that takes trades based on the rsi. If the rsi is below 30 it sells and if above 70 it buys. Now the EA works well on the tester for weeks and then suddenly without changing anything in the code it stops working.
By stops working I mean it starts to skip trades in certain areas with the error 131, 134 and 148. But in other areas on the chart it takes trades fine. Again remember the same EA was working just fine some weeks ago and nothing was changed in the code.

Has anyone seen this and has any pointers on how to fix it? Any help will be so much appreciated.
Alain Verleyen
38714
Alain Verleyen  
trader_queen1:
Hi folks was hoping someone could please help me understand what could be going on with my EA.

I wrote and EA that takes trades based on the rsi. If the rsi is below 30 it sells and if above 70 it buys. Now the EA works well on the tester for weeks and then suddenly without changing anything in the code it stops working.
By stops working I mean it starts to skip trades in certain areas with the error 131, 134 and 148. But in other areas on the chart it takes trades fine. Again remember the same EA was working just fine some weeks ago and nothing was changed in the code.

Has anyone seen this and has any pointers on how to fix it? Any help will be so much appreciated.

The code has note changed but the data (market) has. Fix your code.

And post your code if you need coding help.

trader_queen1
12
trader_queen1  
Alain Verleyen:

The code has note changed but the data (market) has. Fix your code.

And post your code if you need coding help.

Thanks for responding quickly Alain Verleyen!


When I test it on the tester I am testing around the same time timeframe. So for example April 2019 to August 2019. And it works fine in the tester for days or weeks. Then suddenly I load the same EA with the same timeframe of April 2019 to August 2019 and it will start to skip trades in some areas, take trades in some. Same tester same market timeframe no code change. 


Do you have any idea what it could be? the market in my case is the same.

Alain Verleyen
38714
Alain Verleyen  
trader_queen1:

Thanks for responding quickly Alain Verleyen!


When I test it on the tester I am testing around the same time timeframe. So for example April 2019 to August 2019. And it works fine in the tester for days or weeks. Then suddenly I load the same EA with the same timeframe of April 2019 to August 2019 and it will start to skip trades in some areas, take trades in some. Same tester same market timeframe no code change. 


Do you have any idea what it could be? the market in my case is the same.

I have no idea what you did or what happened. But I know 2 things :

1° Something has changed even if you don't know what is. You can eventually investigate further to find out what changed but that will most probably doesn't help you to know it.

Error 131, 134, 148 are the result of coding errors, you have to fix your code.

To add comments, please log in or register