EA self deinits/self-removes after migration because of missing symbols


Hi everyone,

I hope I opened this thread in the right section. The problem I have is the following:

I am using an EA that has worked flawlessly when using it with brokers with "normal" Forex symbols (meaning symbols with a suffix) so far. My my new broker however uses a suffix (".i") behind every symbol. The EA I am using does allow for trading on symbols with suffixes and I edited the EA inputs accordingly (e.g. "EURUSD.i"). However, whenever I try to migrate to my MQL5 VPS, the experts self removes automatically. The journal tells me the EA cant seem to find certain symbols, and keeps asking to add those symbols to the market watch, but they are in fact already in there. I even tried to copy and paste the symbol names as found in the Market Watch .set file into the EA inputs to make sure they match exactly, but it still doesnt work. If I enable AutoTrading on my local MT4 terminal with the exact same configuration however, no errors occur. It seems as if certain symbols get lost/removed from the marketwatch during migration, so once migrated the EA cant find them and therefore removes itself.

I am not sure wether this is a fault with the EA itself or the migration process. I have already contacted the EAs developer about this, answer is pending. Does anyone have an idea as to what the cause could be?