Download MetaTrader 5

WebRequest broken in build 1604?

To add comments, please log in or register
nikinanaliu
28
nikinanaliu  

i have using WebRequest function to send data to the server side and all is running ok before updating to MT5 build 1604. 

after i update to build 1604, WebRequest function was broken and always return error 5200, but the same code at build 1596 is work ok.

does anyone touch the same error ?

or anyone can help me?

nikinanaliu
28
nikinanaliu  

and mt5 client will update to 1604 automatically.

what r u doing for the function WebRequest() ?!!!!!!

Alain Verleyen
Moderator
33618
Alain Verleyen  
nikinanaliu:

and mt5 client will update to 1604 automatically.

No they don't. Only if they connect to Metaquotes-Demo.

what r u doing for the function WebRequest() ?!!!!!!

I confirm this problem (error 5200 with build 1604).

Reported to ServiceDesk. ticket #1763691

nikinanaliu
28
nikinanaliu  
Alain Verleyen:
No they don't. Only if they connect to Metaquotes-Demo.

I confirm this problem (error 5200 with build 1604).

Reported to ServiceDesk. ticket #1763691


before build 1604, it will return error 5200 on https:// but http:// work ok.

i have tried to catch packet of TLS  and i think maybe https also have some problem..

Alain Verleyen
Moderator
33618
Alain Verleyen  
nikinanaliu:


before build 1604, it will return error 5200 on https:// but http:// work ok.

i have tried to catch packet of TLS  and i think maybe https also have some problem..

http and https were working fine in previous build.
Alain Verleyen
Moderator
33618
Alain Verleyen  

Forum on trading, automated trading systems and testing trading strategies

MT5, mql5 bugs to be fixed.

Alain Verleyen, 2017.06.02 16:50

Support Team 2017.06.02 16:24
Thank your for your message.

Fixed. Please wait for updates.

To add comments, please log in or register