Download MetaTrader 5

Mql5 Backtest Object Tooltip not working

To add comments, please log in or register
Somsri Sarkar
2742
Somsri Sarkar  

Hello Members,

I have tested the code on live chart, no problem tooltip showing perfectly, but while doing backtest, no tooltip is showing at the tester chart window. While in case of mql4 programming it works.

Plus the object move function working weirdly.

For example Vertical line printing with custom vline function, along with object move option in there.

On live chart it works perfectly but with backtest with tick by tick, it keeps moving between one place to another 9:30 to 10:00. Original position is 10:00. 

Why such thing is happening? Coding problem or bug?

Thank you in advance

Regards

Somsri Sarkar
2742
Somsri Sarkar  

Why tooltip doesn't show up during indicator backtest totally clueless.

For vertical line changing position during backtesting one to another issue. Here is the code:

for(int ml=0;ml <200; ml++)
{ 
  MTemp[ml] = Calculation;
  
  for(int pl=0; pl < 9; pl++)
    {   
      if(Conditions)
           {
              datetime dt1 = (ND + (ml*300));
              Object_VLine ("objectvline"+IntegerToString(pl),pl,dt1,Stl0,width2,"Level",Name[pl],Col17,"level");
            }
     }
}

//---Seperate Void function for drawing Vlines -----//
void Object_VLine ( string Name1, int Name2, datetime V_Time, int style, int o_width,string first_text, string second_text, color o_col,string aname)
{
               string asp1;
               StringConcatenate(asp1,IntegerToString(Name2),Name1);
               Obj_Name = asp1;
               ObjectCreate(CI,Obj_Name,OBJ_VLINE,0,V_Time,0); 
               ObjectSetInteger(CI,Obj_Name, OBJPROP_COLOR,o_col);
               ObjectSetInteger(CI,Obj_Name, OBJPROP_STYLE,style);
               ObjectSetInteger(CI,Obj_Name,OBJPROP_WIDTH, o_width); 
               ObjectSetInteger(CI,Obj_Name, OBJPROP_BACK,ObjOnBckgrnd);
               ObjectSetInteger(CI,Obj_Name, OBJPROP_SELECTABLE,objectselectable);
               ObjectSetInteger(CI,Obj_Name, OBJPROP_HIDDEN,objecthidden);
               ObjectSetInteger(CI,Obj_Name,OBJPROP_READONLY,ObjReadOnly);
               string as1,aspp1;
               StringConcatenate(as1,first_text,second_text);
               ObjectSetString(CI,Obj_Name,OBJPROP_TEXT,as1);  
               StringConcatenate(aspp1,second_text,aname,TimeToString(V_Time,TIME_MINUTES));
               ObjectSetString(CI,Obj_Name,OBJPROP_TOOLTIP,aspp1);
               ObjectMove(CI,Obj_Name,0,V_Time,0);
               ObjectMove(CI,Obj_Name,1,V_Time,0);
 
}

not sure why its behaving such strangely.

Somsri Sarkar
2742
Somsri Sarkar  

I asked support, no reply yet. It would be good if at least I get know is it the software bug or programming issue about the mt5 backtest tooltip not showing up.

Alain Verleyen
Moderator
32012
Alain Verleyen  
Somsri Sarkar:

I asked support, no reply yet. It would be good if at least I get know is it the software bug or programming issue about the mt5 backtest tooltip not showing up.

They probably have more urgent things to do as to work on a tooltip.
Somsri Sarkar
2742
Somsri Sarkar  
Alain Verleyen:
They probably have more urgent things to do as to work on a tooltip.

It has been 10 days, plus if tooltip doesn't work, my customer will not understand what line is what when they will do the backtest for the products. If Sell commission is not important here. Then its okay.

The only thing I asked is it a programming mistake or a software bug. 

Alain Verleyen
Moderator
32012
Alain Verleyen  
Somsri Sarkar:

It has been 10 days, plus if tooltip doesn't work, my customer will not understand what line is what when they will do the backtest for the products. If Sell commission is not important here. Then its okay.

The only thing I asked is it a programming mistake or a software bug. 

This is clearly a bug.

Don't rely on Metaquotes to fix it, their priorities are not yours. I would suggest you to find a workaround.

To add comments, please log in or register