Download MetaTrader 5

no debugger for mt4-indicators??

To add comments, please log in or register
Carl Schreiber
7301
Carl Schreiber  
Please can s.o. check?

I loaded the simple ATR.mq4 in my mt4.editor (mt4 b 1045 editor: b 1526).

As the debugger button is grey I pretend to save it under a different name but used the same name and confirmed overwriting the original file.

Now if I start the debugger after some graphical action - nothing :(

In both logs I see the same - only:

2017.02.17 12:58:40.096    Custom indicator ATR EURUSD,H1: removed
2017.02.17 12:58:39.832    Custom indicator ATR EURUSD,H1: loaded successfully



For all who don't have the ATR.mq4, it is attached.



Added:

Even if I debug a script calling this indi:
//+------------------------------------------------------------------+
//|                                              Test_debug_Indi.mq4 |
//+------------------------------------------------------------------+
#property strict
void OnStart()  {
   DebugBreak();
   double b00 = iCustom(_Symbol,PERIOD_H1, "ATR",  0,0);
}

the debugger just ignores this line.

May be its a new feature to make mt4 as unpleasant as possible?
Files:
ATR.mq4 4 kb
Carl Schreiber
7301
Carl Schreiber  
I just updated my terminal from b1031 (with which you can debug indicators) to b1052 and even here I just get:

2017.02.28 09:19:08.211    Custom indicator ATR EURUSD,H1: removed
2017.02.28 09:19:07.962    Custom indicator ATR EURUSD,H1: loaded successfully

For a second the minimized terminal appeared and showed the setup-box and everything disappeared again!

So if you want to use the debugger for indicators and you have b1031 and you are asked for the Admin.-Pwd just say NO and keep b1031.

Be aware that every time you start the debugger the terminals wants to be updated and asks you for the Admin.-Pwd, just keep saying no. It is a bit annoying but is is working!
Fernando Carreiro
2911
Fernando Carreiro  
Carl Schreiber:
I just updated my terminal from b1031 (with which you can debug indicators) to b1052 and even here I just get:

2017.02.28 09:19:08.211    Custom indicator ATR EURUSD,H1: removed
2017.02.28 09:19:07.962    Custom indicator ATR EURUSD,H1: loaded successfully

For a second the minimized terminal appeared and showed the setup-box and everything disappeared again!

So if you want to use the debugger for indicators and you have b1031 and you are asked for the Admin.-Pwd just say NO and keep b1031.

Be aware that every time you start the debugger the terminals wants to be updated and asks you for the Admin.-Pwd, just keep saying no. It is a bit annoying but is is working!
You can use the "/skipupdate" command line option, on both the "terminal" and the "editor" to prevent updates!

I am surprised you are not using it as you yourself "discovered" it when it first came out: "an new terminal start-option: /skipupdate ??"
Carl Schreiber
7301
Carl Schreiber  
Fernando Carreiro:
You can use the "/skipupdate" command line option, on both the "terminal" and the "editor" to prevent updates!

I am surprised you are not using it as you yourself "discovered" it when it first came out: "an new terminal start-option: /skipupdate ??"
  1. I am not against updates especially not in these days!
  2. I absolutely did not expect that the start of the debugger initialized the terminal to update itself! I am used to the situation that closing the terminal might start the update - if available - so I entered the pwd and confirmed.
  3. I absolutely did not expect these problems.
  4. After the update to b1045 the ServiceDesk asked me to update to b1052.
  5. If the update is initialized from 'within' the terminal the option /skipupdate might not work, even if the terminal is restarted after the PC is restarted after e.g. Windows update...
  6. Last but not least I am able to war you.
To add comments, please log in or register