Download MetaTrader 5

tester displaying wrong indicators

To add comments, please log in or register
Keith
368
Keith  

No matter what I do, the tester still shows the same template, which is not related to the Ea being tested.

I have tried different EA, different pairs, different profiles, different initial templates and always get the same template,

which in some cases has  none of the appropriate indicators displayed. 

Thoughts? Suggestions? Brilliant ideas? 

thanks

keith 

Fernando Carreiro
2847
Fernando Carreiro  
Keith: No matter what I do, the tester still shows the same template, which is not related to the Ea being tested.

I have tried different EA, different pairs, different profiles, different initial templates and always get the same template, which in some cases has  none of the appropriate indicators displayed. 

Thoughts? Suggestions? Brilliant ideas?

When you save a template under the name "tester.tpl" it becomes the default template that is used in the Strategy Tester!

To use a different template for a particular EA, you have to save the template with the same name as the EA. For example, if the EA is "ChannelBreak.mq4", then save the necessary template as "ChannelBreak.tpl".

PS! Also make sure that the templates are being saved in the correct folder!

Keith
368
Keith  
Fernando Carreiro:

When you save a template under the name "tester.tpl" it becomes the default template that is used in the Strategy Tester!

To use a different template for a particular EA, you have to save the template with the same name as the EA. For example, if the EA is "ChannelBreak.mq4", then save the necessary template as "ChannelBreak.tpl".

PS! Also make sure that the templates are being saved in the correct folder!

Thank you so much. I do not remember consciously saving  the template as tester, did not even know you could do that, but that was the problem.

I deleted tester.tpl from template file and problem solved.

Thanks again! 

To add comments, please log in or register