Download MetaTrader 5
To add comments, please log in or register
Do you have Linux? Find out how to install MetaTrader on it!
emred
35
emred 2015.10.31 23:10 

Hello,

I am a newbee in metatrader and mql4 language,

I found this library which is exactly what I need (Multicurrency OnTick (string symbol) event handler - expert for MetaTrader 5):

https://www.mql5.com/en/code/280

But It needs MetaTrader 5, my broker version is (TradeMasterFX Meta, Version: 4.00 Build 890)

Is there way to upgrade my terminal to support mql5 functionality?

Or is there a any trick to use mql5 libs and functions?

 

Thanks for your advise,

Best Regards,

Emre 

Doerk Hilger
1074
Doerk Hilger 2015.11.01 10:20  

Hey,

MT4 supports MQL5, you don´t need a trick to use MQL5, just do it.

Doerk 

Amir Yacoby
1127
Amir Yacoby 2015.11.01 12:31  

Doerk, in general you are right.

But, this library won't work on MQL5 because of the spies indicators. Indicators are handled differently on MQL5 and MQL4. 

emred
35
emred 2015.11.01 19:45  

Thanks for your quick replies,

Dear Doerk,

I get following error in the library file of this extension:

'MQL5InfoInteger' - function not defined OnTick(string symbol).mqh 68 21

Please download and try to compile this extension, I wonder if you get same error. 

 

Is there any setting to support mql5 or is there any extra libraries to support mql5?

Thanks for your help. 

 Emre 

Doerk Hilger
1074
Doerk Hilger 2015.11.02 10:50  

Hey,

I did it that way that I cutted down the MT5 libraries in a way, that they work with MT4 too. But to be honest, I don´t use the indicator stuff, sorry.

Doerk 

/
To add comments, please log in or register