Download MetaTrader 5
To add comments, please log in or register
Have you developed an application? Publish it in Code Base!
fbj
1047
fbj 2015.08.08 14:05 

In MetaEditor on EA source I start debugger via F5

In ClientTerminal a new chart is displayed.

I need .tpl of my choice...

Same idea as when use StrategyTester, I name the .tpl of choice with the .ex4's <fname>.tpl 

I've done the renaming in all dirs having .tpl's but no joy.

I've searched total install tree for eg: "symbol=EURUSD" which would appear in the .tpl that ClientTerminal decided to use and no .tpl of any meaning to me has something that ClientTerminal would decide to use. I happens same .tpl each time too.

Any ideas how to use .tpl of my choice when debugging???

Thanks

Carl Schreiber
5951
Carl Schreiber 2015.08.08 15:48  
create a template called debug.tpl
whroeder1
13619
whroeder1 2015.08.08 18:59  
<EAname>.tpl then debug.tpl then default.tpl are the defaults
fbj
1047
fbj 2015.08.08 19:16  
gooly:
create a template called debug.tpl

Thanks for reply but..... 

I created debug.tpl in templates from GBPUSD,M15 - totally clean chart. Beginning of debug.tpl is:

<chart>
id=130733356272852375
symbol=GBPUSD
period=15
...

Makes no difference, I had already tried this [just forgot to mention..]

So, I delete debug.tpl and get up the clean chart and 'save as' debug.tpl

I switch to ME and do F5 with a BP in place to suspend code..

Then, switch back to Terminal and USDCHF,H1 now showing/created - obviously when I hit F5.

If I re-enter ME and do shift-F5 the debug session stops and USDCHF,H1 removed.

debug.tpl still has above beginning - so not moded.

What now? 

Carl Schreiber
5951
Carl Schreiber 2015.08.08 19:42  

The symbol and the time frame for debugging has to be set in the editor: Menu => Tools => Options => Debug.

The debug.tpl loads only the indicators and their setting you would like to see.

Olumide Samson
91
Olumide Samson 2015.08.09 00:00  
fbj:

Thanks for reply but..... 

I created debug.tpl in templates from GBPUSD,M15 - totally clean chart. Beginning of debug.tpl is:

<chart>
id=130733356272852375
symbol=GBPUSD
period=15
...

Makes no difference, I had already tried this [just forgot to mention..]

So, I delete debug.tpl and get up the clean chart and 'save as' debug.tpl

I switch to ME and do F5 with a BP in place to suspend code..

Then, switch back to Terminal and USDCHF,H1 now showing/created - obviously when I hit F5.

If I re-enter ME and do shift-F5 the debug session stops and USDCHF,H1 removed.

debug.tpl still has above beginning - so not moded.

What now? 

 


Creating debug.tpl is not in the form of a file..

Open a new chart load your templates (if any) and save templates again as debug.tpl using save template..
That's it.. You're done.
fbj
1047
fbj 2015.08.09 07:05  
gooly:

The symbol and the time frame for debugging has to be set in the editor: Menu => Tools => Options => Debug.

The debug.tpl loads only the indicators and their setting you would like to see.


The missing link. Thanks :)

Understand why picking up usdchf,h1 now. It was "..first symbol in the Market Watch window..".

Ref: "MetaEditor / MetaEditor Options / Debugging"
"If no symbol or chart period is specified in this tab, then the first symbol in the Market Watch window and period H1 will be used for debugging/profiling on default."

Regards debug.tpl, got that now too. I put whatever chart content  wanted such as special indicators, objects etc. via making copy of wanted .tpl and naming/save template as debug.tpl

Above combo of  "Menu => Tools => Options => Debug" + debug.tpl has sorted me out.

Many thanks to all. Been a long time since I've posted.

MT4 lives on ;)

/
To add comments, please log in or register