Download MetaTrader 5
To add comments, please log in or register
Deposit to your account using bank cards via Gate2Shop
Sezor
77
Sezor 2015.04.02 07:31 

Good day all.

Any suggestions for mt4 charts not loading their template contents? 

On startup or on switching profiles, charts come up without their template contents. 

It's a problem which occurred fitfully years ago but is now systematic for m1 charts, occasional on other timeframes.  

If I reload the template manually, it loads fine. 

the chartnn.chr files all have the correct content - it just doesn't load. 

Drazen Penic
2403
Drazen Penic 2015.04.02 08:48  

Suggestions:

  • check log file for errors during template loading
  • save templates again
  • delete all chartnn.chr files  
  • open request at Service Desk

Sezor
77
Sezor 2015.04.02 09:01  

Thanks Drazen

There are no errors in the log file. 

I'll try the others in a day or 2




Sezor
77
Sezor 2015.04.03 16:07  
Thanks again Drazen
In case it is of help to anyone else, this is what I did :
Of your suggestions:
    check log file for errors during template loading     - none reported
    save templates again - did that, no help
    delete all chartnn.chr files - as this last was going to create a lot of work, I did the following: 
- created a new profile (there being no "new" item in the menu, I saved an existing one to a new name then deleted all its charts and restarted it from zero)
- opened a new chart
- deleted all the indis on it (from old default.tpl)
- closed & restarted mt4
- added indis to the new chart
- saved a new template
- saved that also to default.tpl
- applied the new template to existing charts exhibiting the problem
That seems to have solved it
Sezor
77
Sezor 2015.04.06 14:20  
Monday morning and the problem is back again, even on the
brand new profile with brand new charts and template. 
More precisely, 2 indis load okay, two half load - see
http://screencast.com/t/HWiaVTloL
These are indis which have worked for years, before even the
update to build 600 & ff. 
They exhibit no errors on recompiling. 
Friday's log declares that they loaded successfully numerous
times.
Sezor
77
Sezor 2015.04.06 14:53  

PS

I've discovered that in the templates which omit to load two
indis, those indis are not present in the .chr file. 
I should add that the problem is worst on m1 charts but does
not occur on all of them. 


akki
23
akki 2015.04.15 10:23  
it seems like the prob is solved . but if you got some further issues you can contact me :)
Sezor
77
Sezor 2015.06.30 08:43  
nerd-fold_12:

it seems like the prob is solved . but if you got some further issues you can contact me :)


Thanks

Build 840 seems to have solved the problem


thanks programmers



/
To add comments, please log in or register