Download MetaTrader 5

DDE MT4 Excel calculation issue - value error

To add comments, please log in or register
Daniel Jurnik
142
Daniel Jurnik  

Hello everyone

 

I have some issue with DDE excel spreadsheet. I can't to use the data from table to any calculation. For example, I would like to calculate pip value for USDCHF. So, I use this formula: 10/value of USDCHF. But the result is #VALUE. Is there any solution?

 

Thank you! 

Syed Naufal Gaddafi
1470
Syed Naufal Gaddafi  
Yes. Try widening the column.
Daniel Jurnik
142
Daniel Jurnik  

Thank you, but this is not this type of problem.

Carl Schreiber
Moderator
7962
Carl Schreiber  

Post the formula of a cell in Excel that should receive quotes.

It cannot not be =10/value!

Daniel Jurnik
142
Daniel Jurnik  
Yes, I know. The formula is simple: =10/C3 , where C3 is value of USDCHF. I think the problem is data type, but I don't know how to adjust. It could be a number.
Syed Naufal Gaddafi
1470
Syed Naufal Gaddafi  

LOL ... It is a number in digits. If you can figure out what is C3 ... presto.


Remember.. calculation always involve with numbers. C3 is not a number.

Daniel Jurnik
142
Daniel Jurnik  

I think you don't understand me. C3 (cell) => ='MT4'|BID!USDCHF => value.

 

The problem is that I can't to use this value for any calculation. The result is #VALUE!  

Syed Naufal Gaddafi
1470
Syed Naufal Gaddafi  
Please forgive me when giving little information so that people could answer (very) wrongly (or stupidly).
Carl Schreiber
Moderator
7962
Carl Schreiber  

1) The terminal Help (F1->Search DDE) shows the Excelformula: =MT4|BID!USDCHF   (WITHOUT '' !!)

2) LibreOffice (openOffice)? requires:   =DDE("MT4";"BID";"USDCHF")

3) Have you enabled Terminal -> Tools -> Options -> Server -> Enabled DDE Server?

4) Your spreadsheet allows being updated 'from outside'?

5) You spread-sheet is USA (dec.-point) or EUR (dec.-comma)?

Syed Naufal Gaddafi
1470
Syed Naufal Gaddafi  
I bet one of it (or all). Common newbie mistake.
Daniel Jurnik
142
Daniel Jurnik  
1) The terminal Help (F1->Search DDE) shows the Excelformula: =MT4|BID!USDCHF   (WITHOUT '' !!) - I can't to set Excelformula without ''. Excel will not let me. How to do it?
12
To add comments, please log in or register