Download MetaTrader 5
To add comments, please log in or register
Register as a seller and start making profit!
Rasoul Mojtahedzadeh
25286
Rasoul Mojtahedzadeh 2014.06.27 12:12 

Hi there,

I have installed MT4 Build 646 on my computer. The attached code has been taken from MQL4 help file. The strange thing is that, if you try to compile it with MetaEditor (version: 5.00 build 934 that comes with MT4), the compile will fail with the following error:

'indicator_type1' - invalid property value    test.mq4    9    11

Does anybody know how it could possible that a sample code taken from the MQL4 reference (help file) does not compile?
Files:
test.mq4 7 kb
qjol
3243
qjol 2014.06.27 12:19  

DRAW_COLOR_CANDLES is from MQL5 not 4

Rasoul:

Does anybody know how it could possible that a sample code taken from the MQL4 reference (help file) does not compile?


probably because it's a copy paste from MQL5

Rasoul Mojtahedzadeh
25286
Rasoul Mojtahedzadeh 2014.06.27 12:23  
qjol:

DRAW_COLOR_CANDLES is from MQL5 not 4


probably because it's a copy paste from MQL5

But this is very strange! Just check out the online MQL4 reference, for example, at here:

https://docs.mql4.com/array/arraycopy

it is MQL4 reference that the example has been taked from, right?

qjol
3243
qjol 2014.06.27 12:32  
Rasoul:

it is MQL4 reference that the example has been taked from, right?


right! so what ? like i said it's a copy paste from MQL5

if you're really not satisfied report to servicedesk, See the article MQL5.community - User Memo => 5. Service Desk
/
To add comments, please log in or register