Download MetaTrader 5
To add comments, please log in or register
Improve your rating. Execute orders in Freelance service!
eaguru
20
eaguru 2014.03.08 19:46 

Following the upgrade to the latest MT4 client 610, I have having issues running my EA which has run very stable for over 12 months on previous versions of Meta Trader. I run the EA on a Windows Server 2008.

The error is as follows:

----------------------------------------------------------------------------------------------------

Faulting application name: terminal.exe, version: 4.0.0.610, time stamp: 0x0070be00

Faulting module name: ntdll.dll, version: 6.1.7601.18247, time stamp: 0x521ea8e7

Exception code: 0xc0000005

Fault offset: 0x0002e3be

Faulting process id: 0xcbc

Faulting application start time: 0x01cf3a38a8bde2f0

Faulting application path: D:\MT4\FXCM MT4 Master 1\terminal.exe

Faulting module path: C:\Windows\SysWOW64\ntdll.dll

Report Id: 126cb9b0-a62c-11e3-9002-bc764e11326f

---------------------------------------------------------------------------------------------------

It seems you can crash it at will when changing time frames, while the EA is running. I have tried this on multiple computers and multiple brokers with the same result. Other times when it looks stable, it crashes on it's own accord.

Any support on this issue would be greatly appreciated. Can not progress further until the terminal is stable.




Alain Verleyen
Moderator
28705
Alain Verleyen 2014.03.08 23:15  

Welcome on mql4.com forum,

I don't think we can help you here on the forum unless you post your code. However it's probably more useful for you to report this to the ServiceDesk of Metaquotes (you have to subscribe on mql5.com).

Radu
29
Radu 2014.03.11 14:26  

This bug is indeed in 610. Timeframe change could cause serious problems, including unwanted position opening and chaos. I reported Service Desk and they fixed the error a few days ago. In build 616, this bug is gone, timeframe change works as expected. They promised a new public version maybe in this week.

Until then, you should upgrade to 616 by using the Metaquotes demo server, and try whether this will fix your problem or not.

Alain Verleyen
Moderator
28705
Alain Verleyen 2014.03.11 16:50  
radu:

This bug is indeed in 610. Timeframe change could cause serious problems, including unwanted position opening and chaos. I reported Service Desk and they fixed the error a few days ago. In build 616, this bug is gone, timeframe change works as expected. They promised a new public version maybe in this week.

Until then, you should upgrade to 616 by using the Metaquotes demo server, and try whether this will fix your problem or not.

I recommend to not use Metaquotes server without a good knowledge of what you are doing. 616 is a beta, and all your platform can be automatically upgraded to 616 if you do that.
Radu
29
Radu 2014.03.12 15:29  
angevoyageur:
I recommend to not use Metaquotes server without a good knowledge of what you are doing. 616 is a beta, and all your platform can be automatically upgraded to 616 if you do that.


Thank you for the notice, however the problems caused by 610 are worse and serious, so I don't have the luxury to wait the official release.

/
To add comments, please log in or register