Download MetaTrader 5

In Build600 old ex4 files do not work correctly as they say they should

To add comments, please log in or register
Derek
42
Derek  

When upgrading to Build600 you see this message "Old EX4 files work correctly and exactly the same way as before". HAHAHAHAHAHAHA!

So why is my application not working in Build 600 and it worked perfectly on Build509. I have not changed it or re-compiled it. Should not have to according to this message.

I tried recompiling and still does not work, so I have begun the tedious process of tracking down the problems.

A word of advice - do not upgrade to Build600 unless you have tested your app in a test build600 platform and found it to work correctly.

Ubzen
5390
Ubzen  
Hillderek:

When upgrading to Build600 you see this message "Old EX4 files work correctly and exactly the same way as before". HAHAHAHAHAHAHA!

So why is my application not working in Build 600 and it worked perfectly on Build509. I have not changed it or re-compiled it. Should not have to according to this message.

I tried recompiling and still does not work, so I have begun the tedious process of tracking down the problems.

A word of advice - do not upgrade to Build600 unless you have tested your app in a test build600 platform and found it to work correctly.

Attach the code you're having problems with.
Derek
42
Derek  
ubzen:
Attach the code you're having problems with.
I'd prefer not to reveal my code at this stage, my customers might not like me to do that. I have found that some of the issues I have been able to resolve by re-compiling. There was also a problem with #property no longer allowed in include files in Build 600 that I had to take care of. Most of the remaining issues are related to running my application on offline charts which were created by importing data from external source via my custom script. I have worked with these offline charts without any hassles prior to Build 600. Now they are well and truly stuffed up.
Simon Gniadkowski
Moderator
18021
Simon Gniadkowski  
Hillderek:
I'd prefer not to reveal my code at this stage, my customers might not like me to do that. I have found that some of the issues I have been able to resolve by re-compiling. There was also a problem with #property no longer allowed in include files in Build 600 that I had to take care of. Most of the remaining issues are related to running my application on offline charts which were created by importing data from external source via my custom script. I have worked with these offline charts without any hassles prior to Build 600. Now they are well and truly stuffed up.

You have a thread about this already, please do not double post: https://www.mql5.com/en/forum/149456
Derek
42
Derek  
RaptorUK:
You have a thread about this already, please do not double post: https://www.mql5.com/en/forum/149456

Incorrect. That thread is to do with #property being ignored in include files, for programs that are compiled in build 600. This one is to do with old EX4 files that are compiled before build 600 not working in build 600. They are different issues.
Simon Gniadkowski
Moderator
18021
Simon Gniadkowski  
Hillderek:
Incorrect. That thread is to do with #property being ignored in include files, for programs that are compiled in build 600. This one is to do with old EX4 files that are compiled before build 600 not working in build 600. They are different issues.

What does this refer to ?

There was also a problem with #property no longer allowed in include files in Build 600 that I had to take care of.

Derek
42
Derek  
RaptorUK:

What does this refer to ?


My apologies. You are quite right.
Derek
42
Derek  

Here is an example of on old EX4 script compiled under Build509 that no longer works properly in Build600:

#property show_inputs
int start()
{
MessageBox("iBarShift of Time[3] is " + iBarShift(NULL,0,Time[3]));
return(0);

}

It works fine for OnLine charts but gives wrong result for OffLine chart created by user.

In Build509 the output we see is "iBarShift of Time[3] is 3.

In Build600 the output we see is "iBarShift of Time[3] is -1.

Derek
42
Derek  
This is fixed in build 610.
To add comments, please log in or register