Problem with strategy tester in MT4

To add comments, please log in or register
Vladoo
29
Vladoo  

HI

 

I have a little problem with the strategy tester in my MT4!

 When I put a stop loss in the value tab it gives me same result as I have put no stop loss!

 It doesnt matter which stop loss I put in it gives me always the same statistics!!

 I put stop loss at 5 pips and see after in the statistics that the largest loss trade was 70 pips!! :/

 And also the optimization doesnt work!

 I put everything correctly to test different sl and tp it starts to work and after a little while it makes ping and no optimization results and no optimization graph!!

 Always the same statistics over and over again!!

 

 Please help!

Simon Gniadkowski
17644
Simon Gniadkowski  
Vladoo:

HI

 I have a little problem with the strategy tester in my MT4!

 When I put a stop loss in the value tab it gives me same result as I have put no stop loss!


What value tab ? can you show a screenshot please,    do you mean as a input for your EA ? if you do then the problem is likely to be with your code.
Vladoo
29
Vladoo  
RaptorUK:
What value tab ? can you show a screenshot please,    do you mean as a input for your EA ? if you do then the problem is likely to be with your code.


yes as an input in the value colomn!
Simon Gniadkowski
17644
Simon Gniadkowski  
Vladoo:

yes as an input in the value colomn!
So your EA is not taking any notice of the SL that you set in it's parameters  . . .  it's either a limitation of the EA,  maybe you need to set a higher figure, or there is an error in your code.
To add comments, please log in or register