有没有老师可以把通达信的源码改成mt4的

要添加评论,请登录注册
liu1980
6
liu1980  

罗威KD指标代码

代码(直接复制下面的代码,不要自己敲):

RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;

K:SMA(RSV,M1,1),ColorRed;

D:SMA(K,M2,1),ColorBlue;

J:3*K-2*D,NODRAW,COLORMAGENTA;

FillRgn(K>D,D,K),ColorRed;

DRAWICON(CROSS(K,D),K,4);

DRAWICON(CROSS(D,K),D,5);

判:REF((D*3-K*2)*(HHV(H,(N-1))-LLV(L,(N-1)))/100+LLV(L,(N-1)),1),NODRAW,ColorRed;

预20:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*20-(M1-1)*K)/100,1),NODRAW,ColorBlue;

预50:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*50-(M1-1)*K)/100,1),NODRAW,ColorBlue;

预80:REF(LLV(L,(N-1))+(HHV(H,(N-1))-LLV(L,(N-1)))*(M1*80-(M1-1)*K)/100,1),NODRAW,ColorBlue;

JC:="KD.D">"KD.K";

SC:="KD.K">"KD.D";

金叉天数:BARSLAST(JC),NODRAW,ColorRed;

死叉天数:BARSLAST(SC),NODRAW,ColorBlue;

DRAWICON(COUNT(K>80,1)=1,97,10);

DRAWICON(COUNT(K<20,1)=1,3,11);

DRAWICON(COUNT(K>80,3)=3,97,12);

DRAWICON(COUNT(K<20,3)=3,3,12);

效果如下图:

罗威KD指标效果图

要添加评论,请登录注册