下载MetaTrader 5
要添加评论,请登录注册
MQL5.community的所有活动都清晰可见。查看看板即知晓!
geshohua
18
geshohua 2007.11.01 11:17 

我是股票里用的 很灵的、现在想把他转换成mt4的指标 那个卖出和买入可以也可以写成ea的话最好 谢谢先。

var26:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
var28:=SMA(var26,3,1);
波段王:SMA(var28,3,1),colorred;
趋势:100*(HHV(HIGH,144)-CLOSE)/(HHV(HIGH,144)-LLV(LOW,144)),colorcyan;
LC:= REF(CLOSE,1);
短线:SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100,colorblue;
乖离线:(CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*1000,coloryellow;
卖出:IF(波段王>90 AND 短线>80,-10,0),colorgreen;
买入:IF(波段王<10 AND 短线<30,-10,0),coloryellow;
Var1:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
Var2:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
Var3:=100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),28);
卖出x:=IF(Var1>MA(Var3,6),MA(Var3,6),Var1);
买入提示:IF(卖出x<=10 ,-10,0),coloryellow;

mkdaoyi
150
mkdaoyi 2007.11.02 06:41  

里面的一些字不大明白,请解释一下好吗?

比如:LLV( ) , HHV( ) .

还有,你这里面是用三组指标,每个指标里面有2至4条指标线是吗?

geshohua
18
geshohua 2007.11.02 18:11  

llv指最低价

hhv指最高价

是3条线 就是波段王。短线。和乖离线

大哥有空的时候帮忙写写 。先谢谢了。

okwh
1631
okwh 2007.11.05 05:23  

Var1:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));
Var2:=100-90*(HHV(HIGH,20)-CLOSE)/(HHV(HIGH,20)-LLV(LOW,20));

两个一样,且Var2没有使用

股票是天图,外汇是以分钟计算的,会有效吗?

geshohua
18
geshohua 2007.11.05 17:46  

2个一样的,是一个指标用的 。无所谓。疏忽了。你删除一个好了。谢谢

这个指标对分钟指标一样的 满灵的 一样有效 他计算的30分钟我把数据导入到股票软件测试过 基本上能找到底和顶的 结合基本面可以说90%成功。

大哥有空的时候帮忙写写 。先谢谢了。

geshohua
18
geshohua 2007.11.11 20:54  
怎么没有人帮忙啊  痛苦~~~
jimmy
3
jimmy 2007.12.06 08:50  
你多不解释一下算法,别人怎么帮你呢
liuxiaodong
282
liuxiaodong 2007.12.10 04:12  
站起来说话!
mt520131003
34
mt520131003 2007.12.25 18:46  

根本看不懂你的指标意思。

b8866
25
b8866 2007.12.29 05:04  

LLV(LOW,27) //LOW是单根K线的最低价,LLV(LOW,27)是27根K线中的最低价的最低值

hhv:指取范围内的最大值,比如HHV(MA10,20)就是说取20个范围MA10均线的最大值

llv:指取范围内的最小值,比如HHV(MA10,20)就是说取20个MA10均线的最小值

HHV,LLV在转换成mt4,用哪个函授,如何表示?

hzs
45
hzs 2008.01.04 17:02  

这个应该不会太难吧。是否有用就不知道了。

/ /12
要添加评论,请登录注册