下载MetaTrader 5
要添加评论,请登录注册
您已经开发一个应用程序了吗?在代码库中发布它!
zealee
17
zealee 2009.10.23 15:07 

我有移中平均线MMV源码,想做成MT4指标,怎么做呢? 求助。

zealee
17
zealee 2009.10.23 17:03  
怎么这么没人气啊,,,,请加我的QQ
BinBin Lu
68
BinBin Lu 2009.10.24 10:22  
zealee 写道 >>

我有移中平均线MMV源码,想做成MT4指标,怎么做呢? 求助。

请把源码传上来。

zealee
17
zealee 2009.10.26 22:54  

移中均线之移中源码:
MA1:MA(CLOSE,21);
REF(MA(CLOSE,21),-(n+1)/2),colorred,linethick4;
后面的-(n+1)/2天是使用了未来函数的,慎重使用!
你可以用右键在mmv指标上测试未来数据,结果可以看到是用了未来函数的

MA1:=MMA(CLOSE,N1);
MA2:=MA(CLOSE,N2);
ENTERLONG:cross(ma1,ma2);{多头买入}
EXITLONG:cross(ma2,ma1);{多头卖出}
{N1<N2}

  函数公式:
  MMV 移中平均线
  MA1:MA(CLOSE,N1);
  MA2:MMA(CLOSE,N1);
  N1 缺省21 最小3 最大121
  MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55);
  MM:=(IF(((DATATYPE > 5) AND (DATATYPE < 9)),MA(MMV,1),IF((DATATYPE = 5),MA(MMV,4),IF((DATATYPE = 4),MA(MMV,8),IF((DATATYPE = 3),MA(MMV,16),IF((DATATYPE = 2),MA(MMV,32),0))))) );
  大智慧软件移中平均线源码:
  MA1:MA(CLOSE,21);
  REF(MA(CLOSE,21),-(n+1)/2),colorred,linethick4;
  后面的-(n+1)/2天是使用了未来函数.
  飞狐软件移中平均线源码:
  input:P1(21,1,300);
  MA1:MA(CLOSE,P1);
  B1:=BACKSET(ISLASTBAR,10);
  B2:=(BARSLAST((B1 > REF(B1,1))) + 1);
  B3:=REFX(MA1,10);
  MA3:=MA(CLOSE,11);
  MA2:IF((B1 = 1),(MA3 - (((REF(MA3,B2) - B3) * (10 - B2)) / 10)),B3),PRECISION2;

是薛斯通道编制的方法,飞狐可以用fft代替;
v1:=ma(HIGH,30)*1.15 ;
v2:=ma(HIGH,3)*1.03;
v3:=ma(LOW,3)*0.97;
v4:=ma(LOW,30)*0.85;
{v5}大通道上:=fft(v1,30);
{v6}小通道上:fft(v2,30),COLORBLUE;
{v7}小通道下:fft(v3,30),COLORBLUE;
{v8}大通道下:=fft(v4,30);
A1:=大通道上-REF(大通道上,1);
A2:=小通道上-REF(小通道上,1);
A3:=小通道下-REF(小通道下,1);
A4:=大通道下-REF(大通道下,1);
PARTLINE(A1>0,大通道上) LINETHICK1 COLORRED;
PARTLINE(A1=0,大通道上) LINETHICK1 COLORWHITE;
PARTLINE(A1<0,大通道上) LINETHICK1 COLORGREEN;
PARTLINE(A2>0,小通道上) LINETHICK1 COLORyellow;
PARTLINE(A2=0,小通道上) LINETHICK1 COLORWHITE;
PARTLINE(A2<0,小通道上) LINETHICK1 COLORblue;
PARTLINE(A3>0,小通道下) LINETHICK1 COLORyellow;
PARTLINE(A3=0,小通道下) LINETHICK1 COLORWHITE;
PARTLINE(A3<0,小通道下) LINETHICK1 COLORblue;
PARTLINE(A4>0,大通道下) LINETHICK1 COLORRED;
PARTLINE(A4=0,大通道下) LINETHICK1 COLORWHITE;
PARTLINE(A4<0,大通道下) LINETHICK1 COLORGREEN;

基本原理按美国J.M.HURST先生发明的HURST通道理论,HURST通道的理论核心就是对移动平均线进行移中以及通道的周期性,修改的后移动平均线对后市的预测有着非常高的准确率
该指标设计很容易,只要解决将平均线前移数日标注即可,方法:
一般短期线按13日移动平均线设置,中期线按26日移动平均线设置,常规都在当日标注,但移中平均线要求把计算出来的13日和26日移动平均线分别前移7天和13天位置标注,就是13日的移动平均线7天前标注,26日的移动平均线13天前标注。这就是移中平均线。以后预测就要靠人工了,电脑做不到。
这时你会发现股价会始终围绕着这2条短中期的移中平均线上下波动,这里有2个特点:
1。无论股价如何变动都离不开移中线,
2。由于股价上落,短期移中线(13日)和中期(26日)会发生金叉或死叉,其交叉点就是股价一个上升或下降波段的中位点(你可以用历史资料观察证实)。我们予测就以此位依据,
3。短期移中线(13日)和中期(26日)发生金叉或死叉后股价未来到顶或到底的时间与交叉点的时间间隔大约是5-7天(最多不过10天),每一个股票或股票的每一个上落周期都是如此。

A:REFX(MA(C,13),7);
B:REFX(MA(C,26),13);

这是纯未来数据指标。是很准。实战使用请谨慎。

connect y2k
178
connect y2k 2009.10.27 10:23  

大多数股票分析软件,对自己编程这块的循环,都实现不了。因此用其它办法做变通。

mt4、宏汇(国产软件,与mt4非常相识)这2个分析软件,都实现了循环的功能。因此编程方面就比较简单了。

connect y2k
178
connect y2k 2009.10.27 10:27  
zealee 写道 >>

基本原理按美国J.M.HURST先生发明的HURST通道理论,HURST通道的理论核心就是对移动平均线进行移中以及通道的周期性,修改的后移动平均线对后市的预测有着非常高的准确率
该指标设计很容易,只要解决将平均线前移数日标注即可,方法:
一般短期线按13日移动平均线设置,中期线按26日移动平均线设置,常规都在当日标注,但移中平均线要求把计算出来的13日和26日移动平均线分别前移7天和13天位置标注,就是13日的移动平均线7天前标注,26日的移动平均线13天前标注。这就是移中平均线。以后预测就要靠人工了,电脑做不到。
这时你会发现股价会始终围绕着这2条短中期的移中平均线上下波动,这里有2个特点:
1。无论股价如何变动都离不开移中线,
2。由于股价上落,短期移中线(13日)和中期(26日)会发生金叉或死叉,其交叉点就是股价一个上升或下降波段的中位点(你可以用历史资料观察证实)。我们予测就以此位依据,
3。短期移中线(13日)和中期(26日)发生金叉或死叉后股价未来到顶或到底的时间与交叉点的时间间隔大约是5-7天(最多不过10天),每一个股票或股票的每一个上落周期都是如此。

感觉没那么复杂。应该和布林通道(保力加通道)指标相似。可能只需要修改参数就,完全一样了。
zealee
17
zealee 2009.11.15 20:11  
y2k_connect 写道 >>

大多数股票分析软件,对自己编程这块的循环,都实现不了。因此用其它办法做变通。

mt4、宏汇(国产软件,与mt4非常相识)这2个分析软件,都实现了循环的功能。因此编程方面就比较简单了。

你会吗?加我Q和我说吧!

/
要添加评论,请登录注册