VPS carica 2 volte gli indicatori che poi non funzionano

 

Buongiorno

Sto riscontrando questo problema lavorando con MT5 sulla VPS di metatrader. Faccio lavorare più expert contemporaneamente sullo stesso account e stessa vps, su simboli diversi, ma anche gli stessi a volte, logicamente con magic number diversi per ogni ea.

Capita questo: quando faccio la migrazione prima carica correttamente sia gli expert che gli indicatori e poi ricarica nuovamente gli indicatori, cosicché mi ritrovo col doppio degli indicatori caricati.

Quindi gli ea cominciano a fare operazioni strane, che non dovrebbero fare, e sembra siano legate proprio ad errori di lettura degli indicatori.

Se vado a vedere sul registro degli expert, in cui mi stampa la situazione per ogni candela, trovo questa situazione:
C'è un indicatore che restituisce 0 oppure 1. Stanno tutti su 0 e questo è un errore. Come se non leggesse l'indicatore.

Poi nelle candele successive alcuni cominciano a cambiare e a ripassare su 1.

Non so se avete esperienza di questo genere di errore, da cosa può essere dovuto

Grazie

 
È difficile capire il tuo problema senza codice, screenshot o log.
 
Alain Verleyen #:
È difficile capire il tuo problema senza codice, screenshot o log.

Magari era qualcosa di semplice da risolvere.

Comunque allego sia il log degli expert che il journal della vps del giorno in cui ho caricato gli ea.


Alle 19.17 circa li inserisco e come puoi vedere prima carica correttamente tutto e poi ricarica di nuovo gli indicatori

Nelle stampe per ogni candela come puoi vedere il valore "S/L" sta a 0 su tutti (ovvero buy) ed è un errore perché visivamente gli indicatori al momento del caricamento stavano alcuni su buy e altri su sell.

Poi dalle candele successive alcuni iniziano a tornare su sell

File:
20230504.log  1635 kb
20230504.log  244 kb
 
Fabio.Andreoli # :

Magari era qualcosa di semplice da risolvere.

Comunque allego sia il log degli expert che il journal della vps del giorno in cui ho caricato gli ea.


Alle 19.17 circa li inserisco e come puoi vedere prima carica correttamente tutto e poi ricarica di nuovo gli indicatori

Nelle stampe per ogni candela come puoi vedere il valore "S/L" sta a 0 su tutti (ovvero buy) ed è un errore perché visivamente gli indicatori al momento del caricamento stavano alcuni su buy e altri su sell.

Poi dalle candele successive alcuni iniziano a tornare su sell

Capisco, ma il problema è legato al tuo EA. Dovresti aggiustarlo, se non l'hai codificato, chiedi all'autore.
 
Alain Verleyen #:
Capisco, ma il problema è legato al tuo EA. Dovresti aggiustarlo, se non l'hai codificato, chiedi all'autore.

ok ma a cosa può essere dovuto? nessuna idea?

 
Fabio.Andreoli # :

ok ma a cosa può essere dovuto? nessuna idea?

Qualcosa non va nel tuo codice, impossibile da indovinare senza vederlo.
Motivazione: