What does the defaults selection do in the optimization inputs

Lorentzos Roussos  

I load a set file in the optimization inputs in mt5 .

Then i right click and hit "defaults" , nothing changes . 


Fernando Carreiro  
Lorentzos Roussos: I load a set file in the optimization inputs in mt5 . Then i right click and hit "defaults" , nothing changes . 

"Defaults" are the default values in the EA code, not the ".set" files.


Or have I misunderstood your question?

Lorentzos Roussos  
Fernando Carreiro #:

"Defaults" are the default values in the EA code, not the ".set" files.


Or have I misunderstood your question?

Yes , i want to load the defaults from the code and it does not respond it keeps the set file

Fernando Carreiro  
Lorentzos Roussos #: Yes , i want to load the defaults from the code and it does not respond it keeps the set file
What build?
Fernando Carreiro  
Lorentzos Roussos #: 3550
I'm using build 3550 and I tried it on mine and I am unable to replicate your issue. Are you sure your EA code has different values to the ones in the ".set" file?
Fernando Carreiro  
Lorentzos Roussos: I load a set file in the optimization inputs in mt5 . Then i right click and hit "defaults" , nothing changes . 

Your screenshot does not seem to be of the "Inputs" tab but of the "Optimisation Results" report.

Maybe I am misunderstanding your post?

Lorentzos Roussos  
Fernando Carreiro #:
Your screenshot does not seem to be of the "Inputs" tab but of the "Optimisations" report. Maybe I am misunderstanding your post?

Its on the inputs tab

Fernando Carreiro  
Lorentzos Roussos #:Its on the inputs tab

Then why are there no column headings in your screenshot?


Lorentzos Roussos  
Fernando Carreiro #:

Then why are there no column headings in your screenshot?


its on the inputs 

Fernando Carreiro  
Lorentzos Roussos #: its on the inputs 

Ok! However, I'm unable to replicate the issue on my setup. Even after loading a .set "file", the "Defaults" still works ...


Reason: