Download MetaTrader 5

Examples: Why Is It Important to Update MetaTrader 4 to the Latest Build by August 1?

To add comments, please log in or register
Having difficulties in understanding the Trading Signals service? Read the article!
MetaQuotes Software Corp.
Moderator
181174
MetaQuotes Software Corp. 2014.06.04 14:10 

New article Why Is It Important to Update MetaTrader 4 to the Latest Build by August 1? has been published:

From August 1, 2014, MetaTrader 4 desktop terminals older than build 600 will no longer be supported. However, many traders still work with outdated versions and are unaware of the updated platform's features. We have put a lot of effort into development and would like to move on with traders and abandon the older builds. In this article, we will describe the advantages of the new MetaTrader 4.

Author: MetaQuotes Software Corp.

To add comments, please log in or register