Purchased two MTF indicators, get "version of {indicator} is obsolete; please recompile it", why?

Premier Global Holdings
641
Matthew Renner  
I've purchased two MTF indicators from two different developers.  Any time I toggle the timeframe to something other than "current" I get the error in Experts tab "version of {indicator} is obsolete; please recompile it".  What is going on?  Is it that difficult to create MTF indicators in MQL5?
Vladimir Karputov
Moderator
247498
Vladimir Karputov  
Matthew Renner :
I've purchased two MTF indicators from two different developers.  Any time I toggle the timeframe to something other than "current" I get the error in Experts tab "version of {indicator} is obsolete; please recompile it".  What is going on?  Is it that difficult to create MTF indicators in MQL5?

You should write about such an error in the product discussion. Also inform the seller of the Market with a personal message about such an error. The seller is obliged to correct this error.

Premier Global Holdings
641
Matthew Renner  
Vladimir Karputov:

You should write about such an error in the product discussion. Also inform the seller of the Market with a personal message about such an error. The seller is obliged to correct this error.

1) Where is product discussion?  There is no section for that in the forum.

2) What actually enforces the seller to correct the error?  He has already tried twice but cannot do it.  He could just give up and walk away.

Without a way to actually contact customer service, there is nothing.  After this, purchasing anything here is like playing Russian Roulette!

Sergey Golubev
Moderator
121497
Sergey Golubev  
Matthew Renner:

1) Where is product discussion?  There is no section for that in the forum.

2) What actually enforces the seller to correct the error?  He has already tried twice but cannot do it.  He could just give up and walk away.

Without a way to actually contact customer service, there is nothing.  After this, purchasing anything here is like playing Russian Roulette!

Discussion about the Market products is prohibited on the forum.
If it is bug in the poducts (in the code, means: the code may be not compatible with new build of Metatrader) so you should contact with the seller anyway.
We on the forum are not able to help with this situation.