confused about optimiser

 

It's all in this little screencast. Any help much appreciated ! 

***

thanks !

 
  1. Please use the link button Use the link button (Control+K) See the difference?  ***
              Messages Editor

  2. You turned off optimization but you did not change the parameter settings in the tester: Expert Properties → inputs → reset
 

Thank. I tried again. This time I reset the input data in the EA properties. The report just gave me all zeros. Then I removed the "input" keywords from my variables, recompiled and tried again. The report showed all zeros again. Here's a screenshot.

Files:
Capture.JPG  91 kb