Download MetaTrader 5
To add comments, please log in or register
Do you need private account monitoring? The Signals will provide you one!
Mideel
74
Mideel 2015.04.30 12:43 

I just finished my EA and have tested it in back test it a couple of days ago but then I did everything the same and it gave 1.000.000 $ different in result.

I used the same unmodified EA.

I used the same parameters or setting.

I used the same symbol, time frame and back test length.


My EA only trade per bar and not per tick, it returns immediately if there's no new bar and my broker use fixed 3 spread.

Some of the testings that I've done before yesterday were during offline mode but some were during online and they still showed the same result ( around 10 times ) before yesterday.

Some of the first testing results generated TestGenerator Error mismatched data or something like that a couple of times but after it some were fine and still gave the same result until yesterday.

Also, I back test from 1 Jun 2014 to 24 April 2015 with 1 hour time frame, in the first result report less than 6000 bars were tested but in the second one more than 6000 bars were tested ( but I didn't change anything ).


So my questions are:

1. How to get the first back test result again because now its always the same second result ?

2. Which result do you think is more valid ?


Here is the first result graph


First Result Graph


Here is the first result report:



First Result Report


Here is the second result graph:


Second Result Graph


Here is the second result report:


Second Result Report

whroeder1
13597
whroeder1 2015.04.30 15:26  

mideel: my broker use fixed 3 spread.

  1. 3 what? 3 points or 3 pips. Does your boker use a fixed spread or an average spread of 3?
  2. What value (points) did you use in the tester?
Mideel
74
Mideel 2015.04.30 16:11  
WHRoeder:
  1. 3 what? 3 points or 3 pips. Does your boker use a fixed spread or an average spread of 3?
  2. What value (points) did you use in the tester?

1. My broker is Instaforex and they use 3 pips fixed spread.

2. Yep, I leave it to the current value in the spread combo box.


And in the first line of the journal, it said TestGenerator current 3 spread used, its offline.


And another note, if it can be a clue... in the first testing result the number of bars tested were less than 6000 but its more than 6000 next although I didn't change anything... just like the two reports that I showed above...


Now I always get the same second result... but I want to see the 1st again if its possible...

/
To add comments, please log in or register