Download MetaTrader 5

How to "ignore" the stoploss value when the market is closing at the end of the week.

To add comments, please log in or register
Snelle Moda
605
Snelle Moda 2013.11.18 11:19 

Hi.

 

Last Friday, the stoploss was triggered on my EURNZD EA (demo) just before the market closed. I have seen this before in other currency pairs (AUDUSD and NZDUSD). 

This was caused by the extreme spread when there is too little liquidity in the market.

 

See example. 

 

 

Is there a possibility to ignore/disable the stoploss value a few minutes before the market closes, when the spread has an extreme value? 

Deleting or adjusting the stoploss value itself is not an option because when the market reopens on sunday/monday night, my EA is not activated, so the stoploss value can't be calculated again.

 

Detecting the time and day of the week is easy, this is not an issue.

 

Has anyone a solution for this problem?

 

Thanks. 

Alain Verleyen
Moderator
31085
Alain Verleyen 2013.11.18 12:24  

Something like 42 pips spread ! It's huge.

There is no way to ignore/disable a stoploss. It's an order placed at the broker side. One option is to use a pending order instead of a stoploss order. In your example you could use a buy stop order with an expiration date. But you have to reenter a new one when to market reopens.

The other solution is to manage this with your EA, but then it needs to run all the time.

Snelle Moda
605
Snelle Moda 2013.11.20 10:02  
angevoyageur:

Something like 42 pips spread ! It's huge.

There is no way to ignore/disable a stoploss. It's an order placed at the broker side. One option is to use a pending order instead of a stoploss order. In your example you could use a buy stop order with an expiration date. But you have to reenter a new one when to market reopens.

The other solution is to manage this with your EA, but then it needs to run all the time.

  

 

Hi

Thanks for your reply.

 

I think your idea for using a pending order is the best solution. Five minutes before the market closes, The stoploss order is removed and replaced by an pending order. On monday, when the EA is reactivated. The pending order is removed and replaced by a new stoploss order.

 

But it's strange that this "problem" is never mentioned before because I have seen this several times last months.

To add comments, please log in or register