Download MetaTrader 5

Weird issue on OBJ_BITMAP_LABEL click

To add comments, please log in or register
Eric Venturi-Bloxs
1068
Eric Venturi-Bloxs  

Hello all,

I have a serious issue and I am not sure what is wrong. I am plotting 3 identical OBJ_BITMAP_LABEL on the chart (different names and positions on chart of course). Then set something to be done when click on them (CHARTEVENT_OBJECT_CLICK).

2 objects work perfectly ... but the 3rd one works only if the click is on the left side of the object ... while the other 2 accept a click anywhere on them.

I would greatly appreciate some help on this!

Thank you.

Eric

honest_knave
Moderator
2434
honest_knave  

If anything is overlapping, take a look at OBJPROP_ZORDER

Eric Venturi-Bloxs
1068
Eric Venturi-Bloxs  
honest_knave:

If anything is overlapping, take a look at OBJPROP_ZORDER


No. All 3 objects are placed in the same way on the chart next to each other ... all with z_order = 0.

Thank you.

honest_knave
Moderator
2434
honest_knave  
Can you attach a screen shot?
Alain Verleyen
Moderator
31198
Alain Verleyen  
Eric_:

No. All 3 objects are placed in the same way on the chart next to each other ... all with z_order = 0.

Thank you.

How are we supposed to help without any code ? Please post relevant code to reproduce your issue.
Eric Venturi-Bloxs
1068
Eric Venturi-Bloxs  
honest_knave:
Can you attach a screen shot?

I played with the z_order and it seems to have fixed the problem. Anyway, I can't understand what was the problem as the 3 objects were plotted withing the exact same environement.

Thank you for your help. You gave me the clue to look at !

Eric Venturi-Bloxs
1068
Eric Venturi-Bloxs  
angevoyageur:
How are we supposed to help without any code ? Please post relevant code to reproduce your issue.


Sorry. Issue seems to be fixed.

Thank you.

To add comments, please log in or register