Download MetaTrader 5

Copy All results from Optimization Results creates one long row, not many rows

To add comments, please log in or register
gilesbutton
20
gilesbutton  
I've run an optimization for a particular EA, when the optimization completes i've gone to "copy all" the results to paste into Excel (which i've done many times successfully with other EA's) it copies the results but in one long row. This is happening across different machines and different installs of MT4. Has anyone else experienced this and if so do you know of a "fix"?
whroeder1
15902
whroeder1  
Paste special?
7188806666
7
7188806666  
gilesbutton:
I've run an optimization for a particular EA, when the optimization completes i've gone to "copy all" the results to paste into Excel (which i've done many times successfully with other EA's) it copies the results but in one long row. This is happening across different machines and different installs of MT4. Has anyone else experienced this and if so do you know of a "fix"?
Have you ever found a solution to this problem? I am running into the exact same problem. If you do have a solution would you please post in to my e-mail Isaac@snowwhite.com . Thanks
Fernando Carreiro
2842
Fernando Carreiro  
7188806666: Have you ever found a solution to this problem? I am running into the exact same problem. If you do have a solution would you please post in to my e-mail Isaac@snowwhite.com . Thanks

In Excel, if it does not separate columns automatically due to differences in Regional Settings, then you must use the "Text to Columns" for separating the columns.

You also must use "Find & Replace" to convert decimal point if you have different regional settings (like using the "," for decimal).

Be extra careful of dates, because in MetaTrader dates are also using "." for separators, so you should first do a Column-wise "Find & Replace" on those columns first, before you do a general "Find & Replace" for decimal point on the entire sheet.

To add comments, please log in or register