Download MetaTrader 5

EA FAILS TO RESTART PROPERLY

To add comments, please log in or register
No PC at hand? Communicate with friends using your mobile phone!
Forex Trader
114255
Forex Trader 2010.06.02 18:33 

Our EA has several Indicators and the EA needed to run. When the MetaTrader4 platform installs it is not rebuilding the executable code using the most recently installed EA and Indicators. We have had to create "New Chart", install our EA and the additional Indicators, and crate a "template" from that "New Chart". We must then apply that template to each of the original charts to have the current/revised EA and Indicators install against the old charts. This problem/process has shut down our users and is causing no end of problems.


Is there a way to force the MetaTrader4 platform to build executable code using the current EA.ex4 and Indicator.ex4 executable code from the "\experts\" and "\experts\indicators\" file folders every time a MetaTrader platform start up is preformed? Or is there a way to cause the MetaTrader4 flush the code as it closes to insure the new EA.ex4 and Indicator.ex4 code is used on the next start up?


The problem does not affect every chart on the platform, only some, randomly. This is a most perplexing problem and very disruptive to our users.

We are experiencing this problem on Windows 7, Vista, and XP platforms. Occurs on builds 225 and 226. Appears to be a problem with bringing in the old executable pointers from the last MetaTrader4 platform execution.


Any and all suggestions are welcome.


Thanks in advance for your assistance.

To add comments, please log in or register