Strategy agent won't disable cores

To add comments, please log in or register
tim_the_coder
8
tim_the_coder  

My MT5 won't disable cores when running a back test, it shows gray and disabled in backtest agent but Task Manager still shows CPU is on 100% all cores

Here is what happened:


I usually run backtest 24 hrs and in the day time I will also use the computer for surfing ,gaming etc.

Week before, I'm running backtest on an Intel CPU 7700K

I can simply turn off 3 cores out of 8 to have a not bad experience of gaming.


Days before I just upgrade my computer to an AMD CPU 3950X

I'm running the same system,same EA on backtest.

Yes it it faster,

I turn on all 32 logic cores in MT5, CPU will run 100% on all cores.

I disable 3 cores in MT5, it shows disabled in MT5,but CPU still running on 100% all cores (except one or two cores will have a zigzag on the 100% line,see attached file)

I'm expecting 3 core complete free for other applications,like it used to be.

There is no other application running at the same time


What I tried

I tried turn off cores usage of backtest agent in Task Manager, it doesn't work

I tried turn priority down of backtest agent  in Task Manager, it doesn't work


I assume MT5 doesn't fit AMD cpu very well,or is there any settings need to be set in mt5 or windows?

Does any one have the same issue?

Files:
CPU.PNG 13 kb
mt5.PNG 112 kb
To add comments, please log in or register