So still, what is the product from the marketplace linked to? - page 5

Sergey Golubev  

Purchased products.

There are 3 activations left.


I have this purchased Expert Advisor on one Metatrader: I downloaded it there a long time ago and created the Market folder with it a long time ago.


That is, it was already there (and it attaches to the chart normally).

The second Metatrader (within the same computer) does not have the Market folder in Expert Advisors.


It means that I have to download the Expert Advisor I bought to the second Metatrader and a Market folder will appear on the second МТ5 in Expert Advisors and with this Expert Advisor.



That is, I loaded the Expert Advisor I bought some time ago to another Metatrader (on the same computer) and the Market folder was created in Expert Advisors for the second MT5 and the EA was installed there (and it is docked normally too).

My activations did not change - I had three free activations and they remained unchanged (because I used the same PC and the same OS).

Sergey Golubev  
Сергей Таболин:

OK. MQ-demo is standalone. I will download from it now.


Transferring the downloaded indicator to a shared folder did not lead to anything.

Now I'll do what you probably did.
I manually deleted this bought EA from the Market folder of the second Metatrader, and reloaded the second Metatrader.
The EA is not in the folder -


And in the second Metatrader there is no folder either -


Then I manually (with a mouse) copy this EA from the Market folder of one Metatrader (it is there) to the Market folder of the second Metatrader, and refresh the Expert Advisors folder in the navigator of the second Metatrader, and the Market folder on the second Metatrader appears in the navigator with this EA, and it attaches normally-


Alexey Viktorov  
Sergey Golubev:

I installed the indicator on the first Metatrader, it appeared in the Market folder (the Market folder was created in Indicators) and the indicator is attached to the chart. For the sake of the experiment - I restarted the computer - the Market folder did not appear in another MetaTrader by itself. That is, I had to install the same indicator in another MetaTrader. And the folder appeared there too (with the indicator), but it was not common for all, but separate for each Metatrader.

Two MT5s, and two Market folders: one for each Metatrader:


So the "Market" folder has to be present? Why do you think that simply copying it to the other terminal is not enough?

ps; I later read that my second question had no merit.

Sergey Golubev  
Alexey Viktorov:

Does the "Market" folder have to be present? Why do you think that simply copying to another terminal is not enough?

ps; I later read that my second question has no basis.

On pure Metatrader I didn't have this folder.
I think the folder is created automatically if something is installed from Market.

Whether the folder can be created manually and whether it will work as if the folder was created by itself - I haven't tried. Probably, you can.
But I've tried something else - if a folder exists and is empty, it is not visible in Metatrader's navigator. And as soon as something appears in a folder - it appears in the navigator.
Maybe it's just possible to copy folders within one computer...
Alexey Viktorov  
Sergey Golubev:
I didn't have this folder on a clean Metatrader.
I think the folder is created automatically if something is installed from Market.

Whether it is possible to create the folder manually and whether it will work as if the folder was created by itself - I haven't tried. You probably can.
But I've tried something else - if a folder exists and is empty, it is not visible in Metatrader's navigator. And as soon as something appears in the folder, it also appears in the navigator.
Maybe it's just possible to copy folders within one computer...

It will work even if copied anywhere.

This indicator was downloaded via browser to one terminal and copied to another via Total Commander

[Deleted]  
Sergey Golubev:

Now I will do what you probably did.
I manually deleted this bought EA from the Market folder of the second Metatrader, and reloaded the second Metatrader.
The EA is not in the folder -


And the second Metatrader doesn't have a folder either -


Then I manually (with a mouse) copy this EA from the Market folder of one Metatrader (it is there) to the Market folder of the second Metatrader, and refresh the Expert Advisors folder in the navigator of the second Metatrader, and the Market folder of the second Metatrader appears in the navigator with this EA, and it attaches normally-


All right, let's go over it again.

We are talking about three terminals installed on the same computer.

  1. Each terminal has opened its own "Indicators" folder (disconnected from the common folder).
  2. I put HMA5 indicator for each one in Indicators/Market folder.
  3. Started each of three terminals in turn and deleted HMA5 directly from them.
  4. Restarted my computer.
  5. Started terminal 1. No Market folder in indicators.
  6. Loaded HMA5 from it. The Market folder appeared and the indicator was successfully placed in the chart.
  7. I closed the terminal and copied the Market folder to Terminal 2 Indicators folder.
  8. Started terminal 2. HMA5 is visible. But it is not applied to the chart.

2019.11.23 16:00:24.308 HMA5    invalid license (538)

But the most interesting thing is next.

Just in case, I copied the Market folder to the Indicators folder of the terminal 3. .... It works.


Then even more interesting. I replaced terminal64.exe in terminal 2 with the same one in terminal 1. The indicator works.... What a mess.

I don't understand anything after that.

  1. I drew simlinks to my Indicators folder again
  2. I copied my Market folder there.
  3. It works in МТ№1.
  4. It did not launch in МТ№2.
  5. The indicator was launched in МТ3.


I have closed access to the shared folder for МТ№2. The same indicator runs from my folder....
Renat Fatkhullin  
Сергей Таболин:

All right, let's do it again.

The next thing is even more interesting. In terminal 2 I replaced terminal64.exe with a similar one from terminal 1. The indicator worked.... Bummer.

Specify which builds of each of the three terminals, please.

If builds float in the mode "activated on new build, and then put the old build", then of course can (can, not 100% will) be a failure due to control of the minimum build.

[Deleted]  
Renat Fatkhullin:

Specify which builds of each of the three terminals, please.

If the builds are floating in "activated on new build and then slipped to old build" mode, then of course there may(may, not 100% will) be a failure due to control of the minimum build.

All MTs with last stable build 2190.

[Deleted]  

Another unpleasant thing has come to light.

It's like this. I made my_HMA5 indicator based on HMA5 (I was practicing). It just changed a little bit the colours of the original one.

#resource   "\\Indicators\\Market\\HMA5.ex5"

Then I made another indicator my_HMA7C_123

#resource   "my_HMA5.ex5"

And finally, due to problems with MT2, my_HMA7C_123_new

#resource   "\\Indicators\\Market\\HMA5.ex5"

I removed my_HMA5.ex5 and HMA5.ex5 to check for included resources

So when running in MT1 and MT3

2019.11.23 19:54:55.081 Indicators      custom indicator my_HMA7C_123 (EURUSD,M15) loaded succesfully
2019.11.23 19:54:55.123 Indicators      custom indicator my_HMA7C_123.ex5::my_HMA5 (EURUSD,M15) loaded succesfully
2019.11.23 19:54:55.162 Indicators      custom indicator HMA5 (EURUSD,M15) loaded succesfully
2019.11.23 19:57:23.570 Indicators      custom indicator my_HMA7C_123_new (EURUSD,M15) loaded succesfully
2019.11.23 19:57:23.609 Indicators      custom indicator HMA5 (EURUSD,M15) loaded succesfully

and in МТ№2.

2019.11.23 19:58:19.763 HMA5    invalid license (538)
2019.11.23 19:58:19.763 my_HMA7C_123.ex5::my_HMA5 (AUDJPY,M30)  cannot load custom indicator 'C:\Users\AvoS\AppData\Roaming\MetaQuotes\Terminal\9058AC2A73B23B65040DD7F3D0DC1303\MQL5\Indicators\my_used\my_HMA7C_123.ex5::my_HMA5.ex5::Indicators\Market\HMA5.ex5' [4802]
2019.11.23 19:58:19.763 my_HMA7C_123.ex5::my_HMA5 (AUDJPY,M30)  Не удалось получить хендл индикатора handle_MA
2019.11.23 19:58:19.763 my_HMA7C_123 (AUDJPY,M30)       BarsCalculated() вернул 0, код ошибки 4603
2019.11.23 19:58:19.764 my_HMA7C_123 (AUDJPY,M30)       BarsCalculated() вернул 0, код ошибки 4603
2019.11.23 19:59:13.933 HMA5    invalid license (538)
2019.11.23 19:59:13.934 my_HMA7C_123_new (AUDJPY,M30)   cannot load custom indicator 'C:\Users\AvoS\AppData\Roaming\MetaQuotes\Terminal\9058AC2A73B23B65040DD7F3D0DC1303\MQL5\Indicators\my_used\my_HMA7C_123_new.ex5::Indicators\Market\HMA5.ex5' [4802]
2019.11.23 19:59:13.934 my_HMA7C_123_new (AUDJPY,M30)   Не удалось получить хендл индикатора handle_MA

Actually because of this I started "digging". If the resource indicator worked well, I probably wouldn't pay attention to HMA5 indicator for a long time...

[Deleted]  

Also, a misunderstanding has surfaced.

I decided to install a clean MT and just plug in my account from MT#2.

As the saying goes - no luck.

2019.11.23 22:42:04.530 Network '50489982': no connection to ............-MT5-Demo

I got my account from "their" terminal and it didn't work.

2019.11.23 22:44:47.272 Network '50489982': authorized on .........-MT5-Demo through MT5-Demo.Europe.3 (ping: 58.88 ms)

Now I have to conclude that this broker somehow modifies the terminal and you can connect to their server only from a modified terminal...

How will MQ react to this, given that this "their" terminal doesn't work the way it's supposed to?

Or maybe there is a spyware module in the terminal? )))