Error 4805 : Does it trade or not ?

Icham Aidibe  

It deserves a topic. Error 4805 not described enough.

An EA with Money Flow Index, gives this error. Two weeks it didn't take any trade, but when running it in the strategy tester, it gives the same error but *trade.*

So I'm not sure on what to do. Any suggestion ?

cannot load indicator 'Money Flow Index' [4805]
with error 4805 : Error applying an indicator to chart
Icham Aidibe  
It displayed the same 4805 error but suddenly opened a trade.
Alain Verleyen  
blouf:

It deserves a topic. Error 4805 not described enough.

An EA with Money Flow Index, gives this error. Two weeks it didn't take any trade, but when running it in the strategy tester, it gives the same error but *trade.*

So I'm not sure on what to do. Any suggestion ?

Nothing else in the logs ?

Can you post the relevant code of your EA ?

Icham Aidibe  
angevoyageur:

Nothing else in the logs ?

Can you post the relevant code of your EA ?

Nope. Nothing else in the log.

    MFIHandle=iMFI(NULL,MFITf,MFIperiod, VOLUME_TICK);
Alain Verleyen  
blouf:

Nope. Nothing else in the log.

I can only suggest you to write to Service Desk.

Edit: Just an idea, what are the values of MFITf and MFIperiod ?

Icham Aidibe  
angevoyageur:

I can only suggest you to write to Service Desk.

Edit: Just an idea, what are the values of MFITf and MFIperiod ?

It now works. I'm expecting the same result in live I got in the strategy tester. wait & see.
Alain Verleyen  
blouf:
It now works. I'm expecting the same result in live I got in the strategy tester. wait & see.
Why ? What's the solution ?
Alain Verleyen  
blouf:
Found out the error the day I posted the topic. But I can't remind what was the error in my code :-/ But now it works, the results are good in the tester. Waiting results of the live I started on Monday, won't be really concluant before at least a month.

An other time, please take it more seriously when you post a question on the forum, people who takes time helping/reading you like to get the solution. A forum is not only to get what you want, it's also and mainly about sharing.

QuantD  

I got the same error today,  it was suddenly and very unexpected because everything works fine.

 

My Stpes.

1. Cleared all caches, charts, ect. files in terminal folder.  ( Did not help )

2. Delete history to reshresh it by new download request from terminal.  ( Did not help )

3.  Change trading server to different one to be sure that is it not server problem.  ( Did not help )

 4. Check all EA setting and have found that for some reason Chart Frame setting for indicators have been cleared, i have set it back to 1H and everything starts work as usual.

 

 Summary for my issue:

  1. if everything was fine and it appears suddenly check all your EA setting if you have time frames setting inside.

  2. Check your EA code for indicators time frame if it happens after you change your code.