MQL5 - Language of trade strategies built-in the MetaTrader 5 client terminal

Automated Trading and Strategy Testing Forum

Write an Article and Earn Money!
To add comments, please log in or register
12next
Subscribe to signals right in MetaTrader. It is easy!
joi
62
joi 2012.07.30 11:52
Rosh:

On your picture I see the Strategy Tester panel. Do you try to debug your EA during back testing? It is impossible at the moment.

May be have launched another copy of your EA on a chart and try to debug one more?

Hello,

thanks for so much help to all!

At last i think i have found the solution. I have installed the MT5 on "D:\" and not on "C:\" and i have choosen another file name.

After deinstalled all and reinstalled all by default, as pruposed on C:\... with the standard file name, all works fine... up to now ;-)

My OnTick()- Funktion is now entered as expected for each tick.

Thanks a lot!

What to Expect From Your Bond Mutual Fund
What to Expect From Your Bond Mutual Fund
Ronnie Mansolillo | 24 October 2014, 10:21 | Views: 55
Oh, right. Stability. That's what bond mutual funds are for. When stock markets tumbled around the world last week, bond funds remained solid once again. They continued to inch ahead, while stock indexes swung up and down by more than 1 percent for five straight days. So many investors poured money into bonds in search of safety that the yield on...
Jin
1510
Jin 2012.08.23 06:12
joi:

Hi, MQL5-experts:

My MetaEditor don't stop at the defined breakpoints. I am starting debugging with F5. The first lines of codes are

int OnInit()
  {
//--- Do we have sufficient bars to work
   if(Bars(_Symbol,_Period)<60) // total number of bars is less than 60?                    // <----- HERE  ***********
     {
      Alert("We have less than 60 bars on the chart, an Expert Advisor terminated!!!");// <---- AND HERE *********
      return(-1);

     ...

I have set breakpoints at the marked lines by doubelklicking the line befor started debugger. The problem is, debugger never stops anywhere and output eacht time the Alert-Error-Message when started.

1) How to enable the debugger to stop?

2) I have defined the TIME_FRAME and Symbol here: Menu->Debug->Options->Debugging..... BUT, where can i define the date-From and date-TO Time-Period (example: 1.7 - 30.7) ???

Thanks for any help!  

Well, I never had any problem with the debugging mode. I just put the breakpoints where I want and then I press F5. For it always works.

About you second doubt, you can't go in debugging mode while simulating. This is why there's no place to put the date FROM and TO.
 

Concerning you problem on entering in debugging mode, try to recompile (press F7) before pressing F5.

 

/ /12next
To add comments, please log in or register